





  

  

  
  

  

  

  

  

  

  

  

  
  

  

  


  

  

  


  

  

  

  

  

  

  

  

  


  

  
    
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Content - Full Width" />
  
    <meta name="oid" content="14966332" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=da050eea6a7f1985054067d737df7b26" />
  <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=da050eea6a7f1985054067d737df7b26" />
  <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=da050eea6a7f1985054067d737df7b26" />
  <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=da050eea6a7f1985054067d737df7b26" />

  

  
  

  
  
    <script src="/foundation/fontawesome/js/brands.min.js" async></script>
    <script src="/foundation/fontawesome/js/solid.min.js" async></script>
    <script src="/foundation/fontawesome/js/regular.min.js" async></script>
    <script src="/foundation/fontawesome/js/fontawesome.min.js" async></script>
    <script src="/foundation/fontawesome/js/light.min.js" async></script>
    <script src="/foundation/fontawesome/js/duotone.min.js" async></script>
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/kanji-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="CITY News RSS: Whole Site" href="https://www.rochestercitynewspaper.com/rochester/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="CITY News RSS: Life Section" href="https://www.rochestercitynewspaper.com/rochester/Rss.xml?oid=12795708" />
    
    
      <link rel="alternate" type="application/rss+xml" title="CITY News RSS: Culture" href="https://www.rochestercitynewspaper.com/rochester/Rss.xml?oid=2124804" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="CITY News RSS: Comments on Culture" href="https://www.rochestercitynewspaper.com/rochester/Rss.xml?id=comments&amp;oid=2124804" />
      
    
  

  

  
    <script>window.__FBAPIv__ = 'v3.2'</script>
  

  
    
      <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
      
      <script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=092c8da693962d93aeed9a8c663b13b1"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=092c8da693962d93aeed9a8c663b13b1"></script>
    
  

  
    
    <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  

  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  
  

  
    
    <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    </script>
  

  <script>
  // Modify user's own profile links to go to correct URL.
  fixupProfileLinks("https:\/\/www.rochestercitynewspaper.com\/rochester\/Profile", "https:\/\/posting.rochestercitynewspaper.com\/rochester\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="680739014388-nuf1n6j57rgv8jjra50l5hbad16nactb.apps.googleusercontent.com">
  

    
  

  
  

  <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
          <script>window.googletag = window.googletag || {cmd: []};</script>
          <script>
            googletag.cmd.push(function() {
              Foundation = Foundation || {};
              Foundation.Ad = Foundation.Ad || {};
              Foundation.Ad.slots = Foundation.Ad.slots || {};
                  Foundation.Ad.slots['div-gpt-ad-city_wallpaper'] = googletag.defineOutOfPageSlot('/1843875/CITY_WALLPAPER', 'div-gpt-ad-city_wallpaper').addService(googletag.pubads());
                  Foundation.Ad.slots['div-gpt-ad-city_leaderboard'] = googletag.defineSlot('/1843875/CITY_LEADERBOARD', [[728, 90], [970, 90]], 'div-gpt-ad-city_leaderboard').addService(googletag.pubads());
                  Foundation.Ad.slots['div-gpt-ad-city_med_rect_1'] = googletag.defineSlot('/1843875/CITY_MED_RECT_1', [[300, 250], [300, 600]], 'div-gpt-ad-city_med_rect_1').addService(googletag.pubads());
                  Foundation.Ad.slots['div-gpt-ad-city_med_rect_2'] = googletag.defineSlot('/1843875/CITY_MED_RECT_2', [[300, 250], [300, 600]], 'div-gpt-ad-city_med_rect_2').addService(googletag.pubads());
                  Foundation.Ad.slots['div-gpt-ad-city_med_rec_3'] = googletag.defineSlot('/1843875/CITY_MED_REC_3', [[300, 250], [300, 600]], 'div-gpt-ad-city_med_rec_3').addService(googletag.pubads());
                  Foundation.Ad.slots['div-gpt-ad-city_sitewide_dd_ad'] = googletag.defineSlot('/1843875/CITY_Sitewide_DD_Ad', [300, 100], 'div-gpt-ad-city_sitewide_dd_ad').addService(googletag.pubads());
                  Foundation.Ad.slots['div-gpt-ad-city_sitewide_ur_ad'] = googletag.defineSlot('/1843875/CITY_Sitewide_UR_Ad', [300, 100], 'div-gpt-ad-city_sitewide_ur_ad').addService(googletag.pubads());
                  googletag.pubads().setTargeting('template', ["Content"]);
                  googletag.pubads().setTargeting('media', ["screen"]);
                  googletag.pubads().setTargeting('section', ["life"]);
                  googletag.pubads().setTargeting('category', ["Culture"]);
                  googletag.pubads().setTargeting('oid', ["14966332"]);
              googletag.pubads().collapseEmptyDivs();
                googletag.enableServices();
              Foundation.Ad.refresh = function (id) {
                if (id && Foundation.Ad.slots[id]) {
                  // Clean up ad container.
                  jQuery('#' + id).css({width: '', height: ''});
                  // Refresh slot.
                  googletag.pubads().refresh([Foundation.Ad.slots[id]]);
                }
                else {
                  // Clean up all ad containers.
                  jQuery('[data-content-type="ad"]').css({width: '', height: ''});
                  // Refresh all (refreshable) slots.  Wish I could use Object.values().
                  var slots = [];
                  for (var id in Foundation.Ad.slots) {
                    if (Foundation.Ad.slots[id].refresh) {
                      slots.push(Foundation.Ad.slots[id]);
                    }
                  }
                  googletag.pubads().refresh(slots);
                }
              };
              // Refresh on foundation:ad:refresh jQuery event.
              Foundation.Ad.refreshlockout = false;
              jQuery(document).on("foundation:ad:refresh", function(event) {
                if (Foundation.Ad.refreshlockout == false) {
                  Foundation.Ad.refreshlockout = true;
                  window.setTimeout(function () {
                    Foundation.Ad.refreshlockout = false;
                  }, 2500);
                  Foundation.Ad.refresh();
                }
              });
              // Mark slots refreshable by default.
              for (var id in Foundation.Ad.slots) {
                if (!('refresh' in Foundation.Ad.slots[id])) {
                  Foundation.Ad.slots[id].refresh = true;
                }
              }
            });
          </script>




<meta name="google-site-verification" content="MK7p28JZYN3KpFUjlcYNrypzqb2B8kvV16nww69JL-A" />
<meta name="google-site-verification" content="35VJLgv516kWfGLi6_2MNNwlGOWgSEneL48dbS9mvaI" />
<meta name="google-site-verification" content="Tw_IYIFDlu_IisIBlHldsSi-cVSL2mP8Izqv4iqzGoE" />
<meta name="google-site-verification" content="vzyHTIgZTfgjJt7KpYoLWT7IGfxSbAghLHrVt7C8e0s" />
  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="CITY Visits...The Puerto Rican Festival of Rochester | Culture | CITY News. Arts. Life." />
  <meta name="description" content="The Puerto Rican Festival returned to Frontier Field. We talked to people reveling in the red, white, and blue-soaked showcase of food, music, and dance." />
  <meta name="keywords" content="News, Arts, Lifestyle, Entertainment, Events, Music, Calendar, Blog, New York, Rochester, Alternative News, Journalism" />
  <title>CITY Visits...The Puerto Rican Festival of Rochester | Culture | CITY News. Arts. Life.</title>

  
  
    <meta name="date" content="2022-08-08 09:02:00" />
  

  
  
  
    <meta name="author" content="Matt Burkhartt, Jeremy Moule">
  

  
  
  <meta name="news_keywords" content="news, arts, lifestyle, entertainment, events, music, calendar, blog, new york, rochester" />

  
  

  
  
  
    <link rel="image_src" href="https://media2.fdncms.com/rochester/imager/u/slideshow/14966532/pr_fest_teaser.png" />
    <meta name="thumbnail" content="https://media2.fdncms.com/rochester/imager/u/slideshow/14966532/pr_fest_teaser.png" />
  

  
    
      <link rel="canonical" href="https://www.rochestercitynewspaper.com/rochester/city-visits-the-puerto-rican-festival-of-rochester/Content?oid=14966332" />
      <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.rochestercitynewspaper.com/rochester/city-visits-the-puerto-rican-festival-of-rochester/Content?oid=14966332" />
    

    
    
    
      
      
      <link rel="amphtml" href="https://www.rochestercitynewspaper.com/rochester/city-visits-the-puerto-rican-festival-of-rochester/Content?oid=14966332&media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="https://www.rochestercitynewspaper.com/rochester/city-visits-the-puerto-rican-festival-of-rochester/Content?oid=14966332" />
    
  

  
    <meta property="fb:app_id" content="347460708667425" />
  

  
  <meta property="og:site_name" content="CITY News" />
  <meta property="og:title" content="CITY Visits...The Puerto Rican Festival of Rochester" />

   
  
    

    
    

    
    

    <meta property="og:image" content="https://media2.fdncms.com/rochester/imager/u/slideshow/14966532/pr_fest_teaser.png" />

    
      <meta property="og:image:width" content="640" />
      <meta property="og:image:height" content="378" />
    
  

  
  
    <meta property="og:description" content="The Puerto Rican Festival returned to Frontier Field. We talked to people reveling in the red, white, and blue-soaked showcase of food, music, and dance." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  

    
    

    
    
    

    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media2.fdncms.com/rochester/imager/u/slideshow/14966532/pr_fest_teaser.png">

    
    

    

    <meta name="twitter:site" content="@roccitynews">
    <meta name="twitter:title" content="CITY Visits...The Puerto Rican Festival of Rochester">
    <meta name="twitter:description" content="The Puerto Rican Festival returned to Frontier Field. We talked to people reveling in the red, white, and blue-soaked showcase of food, music, and dance.">
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">14966332</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20220808112134</Attribute>
        <Attribute name="creationdate">20220808085927</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20220808090200</Attribute>
            <Attribute name="releasedate">20220808</Attribute>
            <Attribute name="releaseepoch">1659963720</Attribute>
            <Attribute name="title">CITY Visits...The Puerto Rican Festival of Rochester</Attribute>
            <Attribute name="author">2256244</Attribute>
            <Attribute name="authorname">Matt Burkhartt</Attribute>
            <Attribute name="authorsortname">Burkhartt, Matt</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
          {
            "mainEntityOfPage": {
              "@type": "WebPage",
              "@id":"https:\/\/www.rochestercitynewspaper.com\/rochester\/city-visits-the-puerto-rican-festival-of-rochester\/Content?oid=14966332"
            },
            "headline": "CITY Visits...The Puerto Rican Festival of Rochester",
            
              "description": "The Puerto Rican Festival returned to Frontier Field. We talked to people reveling in the red, white, and blue-soaked showcase of food, music, and dance.",
            
            "image": {
              "url": "https:\/\/media2.fdncms.com\/rochester\/imager\/u\/original\/14966532\/pr_fest_teaser.png",
              "width": 724,
              "height": 428,
              "@type": "ImageObject"
            },
            "datePublished": "2022-08-08T09:02:00",
            "dateModified": "2022-08-08T11:21:34",
            
              "author": [
                
                  
                  {
                    "name": "Matt Burkhartt",
                    "url": "https:\/\/www.rochestercitynewspaper.com\/author\/matt-burkhartt",
                    "@type": "Person"
                  },
                
                  
                  {
                    "name": "Jeremy Moule",
                    "url": "https:\/\/www.rochestercitynewspaper.com\/author\/jeremy-moule",
                    "@type": "Person"
                  }
                
              ],
            
            "publisher": {
              "name": "CITY News",
              
                
                
                
                "logo": {
                  "url": "https:\/\/www.rochestercitynewspaper.com\/imager\/b\/google-amp-logo\/808579\/b2b5\/rochester-share.png",
                  "width": 1024,
                  "height": 1024,
                  "@type": "ImageObject"
                },
              
              "@type": "Organization"
            },
            "@context": "https://schema.org",
            "@type": "NewsArticle"
          }
        </script>
  


</head>





  <body id="Content" class="ContentFullWidth Culture Kanji10Zone life">



<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  
</div><!-- end gridLeader -->

<div id="gridClamp">

  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader ContentFullWidth " style="display:none">
        
        
          Switch to the <a href="https://m.rochestercitynewspaper.com/rochester/city-visits-the-puerto-rican-festival-of-rochester/Content?oid=14966332" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      
      function setRedirectHash() {
        if (location.hash) {
          jQuery("#MobileDetect a[media='handheld']").each(function() {
            var link = jQuery(this);
            link.attr('href', link.attr('href').split('#')[0] + location.hash);
          });
        }
      }
      setRedirectHash();

      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  

<!-- NEW Google stats tracking code  April 2014-->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-823140-1', 'rochestercitynewspaper.com');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script>



<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-63s4LXm0U50e-"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-63s4LXm0U50e-.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->




<div id="SearchLogin" class="GlobalHeader ContentFullWidth ">

  
  

  
      <div>
    
    

    
      <a href="https://twitter.com/#!/roccitynews" title="Twitter" target="_blank"><img alt="Twitter" src="https://media2.fdncms.com/rochester/imager/twitter/u/original/2137392/twitter_new.gif" width="29"></a>
    

    
  
    

    
      <a href="https://www.facebook.com/CityNewspaper" title="Facebook" target="_blank"><img alt="Facebook" src="https://media2.fdncms.com/rochester/imager/facebook/u/original/2137427/facebook_new.gif" width="29"></a>
    

    
  
    

    
      <a href="https://www.instagram.com/roccitynews/" title="Instagram" target="_self"><img alt="Instagram" src="https://media1.fdncms.com/rochester/imager/u/original/10871592/instagram-transparent.jpg" width="29"></a>
    

    
  
    

    
      <a href="/rochester/Syndication" title="RSS" target="_self"><img alt="RSS" src="https://media2.fdncms.com/rochester/imager/rss/u/original/2124579/rss.gif" width="29"></a>
    

    
  
    

    
      <a href="http://www.issuu.com/roccitynews" title="Digital Issues" target="_blank"><img alt="Digital Issues" src="https://media1.fdncms.com/rochester/imager/digital-issues/u/original/2124580/issuu.jpg" width="29"></a>
    

    
  
    

    
      <a href="https://mailchi.mp/rochester-citynews.com/newsletters" title="Subscribe to Newsletter" target="_blank"><img alt="Subscribe to Newsletter" src="https://media1.fdncms.com/rochester/imager/u/original/10871942/enews-icon.png" width="29"></a>
    

    
  
      </div>
    



  
  
  
  
    
    <ul data-view="loggedin" style="display:none">
      <li><strong data-label="username">Username</strong> / </li>
      <li><a href="https://posting.rochestercitynewspaper.com/rochester/MyProfile">View Profile</a> / </li>
      <li><a href="https://posting.rochestercitynewspaper.com/rochester/Profile/MySettings">Edit Profile</a> / </li>
      <li><a href="https://www.rochestercitynewspaper.com/rochester/Logout">Log Out</a></li>
    </ul>

    <ul data-view="loggedout" style="display:none">
      <li><a href="#LogIn">Log in</a> / </li>
      <li><a href="#CreateAccount">Create Account</a></li>
    </ul>
  
  

  

  

  <div id="SearchLoginSiteSearchBox">
    <form class="search-form" action="https://posting.rochestercitynewspaper.com/rochester/Search">
      <input type="hidden" name="cx" value="017793458706336421686:dgaybk9sose">
      <input type="hidden" name="cof" value="FORID:9">
      
        <input class="search-input" autocomplete="off" type="text" value="" name="q" size="25" placeholder="">
      
      <div class="searchIcon">
        Search
        <svg version="1.1" id="SearchLoginSiteSearchBoxLayer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="14px" height="14px" viewBox="0 0 14 14" style="enable-background:new 0 0 14 14;" xml:space="preserve"><path d="M10.171,8.766c0.617-0.888,0.979-1.964,0.979-3.126c0-3.037-2.463-5.5-5.5-5.5s-5.5,2.463-5.5,5.5s2.463,5.5,5.5,5.5 c1.152,0,2.223-0.355,3.104-0.962l3.684,3.683l1.414-1.414L10.171,8.766z M5.649,9.14c-1.933,0-3.5-1.567-3.5-3.5 c0-1.933,1.567-3.5,3.5-3.5c1.933,0,3.5,1.567,3.5,3.5C9.149,7.572,7.582,9.14,5.649,9.14z"></path></svg>
      </div>

      
      
        <input type="submit" name="sa" value="Search">
      

      <ul class="search-dropdown" style="display:none;">
        
        
          <li class="search-option"><a class="search-all" href="https://posting.rochestercitynewspaper.com/rochester/Search"><span class="search-icon"></span> All</a></li>
    <li class="search-option"><a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives"><span class="search-icon"></span> in Articles &amp; Posts</a></li>
    <li class="search-option"><a href="https://www.rochestercitynewspaper.com/rochester/EventSearch"><span class="search-icon"></span> in Events</a></li>
    <li class="search-option"><a href="https://www.rochestercitynewspaper.com/rochester/LocationSearch"><span class="search-icon"></span> in Locations</a></li>
    <li class="search-option"><a href="https://www.rochestercitynewspaper.com/rochester/SlideshowArchives"><span class="search-icon"></span> in Slideshows</a></li>
        
      </ul>
    </form>

    
      <script>
      "use strict";
      (function(){
        var searchPanel = new Foundation.View.Desktop.RevealPanel({
          hoverSelector: '#SearchLoginSiteSearchBox div.searchIcon',
          clickSelector: '#SearchLoginSiteSearchBox input.search-input',
          panelSelector: '#SearchLoginSiteSearchBox ul.search-dropdown',
          alignSelector: '',
          alignFunction: function(){}
        });

        var searchFormSelector = '#SearchLoginSiteSearchBox form.search-form'
        var searchOptionLinkSelector = '#SearchLoginSiteSearchBox li.search-option a'
        var searchInputSelector = '#SearchLoginSiteSearchBox input.search-input'

        var canProceed = function(obj, searchAllOption){
          var emptyKeyword = jQuery(searchInputSelector).val().trim().length === 0
          // Don't proceed without a keyword on the search-all option
          if(emptyKeyword && searchAllOption){
            return true // allow submission without keyword
          }
          return true
        }

        var enterKeywordMessage = function (){
          jQuery(searchInputSelector).attr('placeholder',"Enter a keyword.")
          window.setTimeout(function(){
            jQuery(searchInputSelector).attr('placeholder',"")
          },1000)
        }

        // 
        jQuery(searchFormSelector).submit(function(e){
          if(!canProceed(e.target, true)){
            e.preventDefault()
            enterKeywordMessage()
          }
        })

        // 
        jQuery(searchOptionLinkSelector).on('click', function(e){
          e.preventDefault()
          if(canProceed(e.target, jQuery(e.target).hasClass('search-all'))){
            if(jQuery(e.target).hasClass('search-all')){
              jQuery(searchFormSelector).submit()
            } else {
              var newLocation = jQuery(e.target).attr('href') || ""
              var catVal = jQuery(e.target).attr('data-category')
              var catParam = catVal != undefined ? "&category="+catVal : ""
              window.location = newLocation 
                              + "?keywords=" + jQuery(searchInputSelector).val() 
                              + "&submit=Search" 
                              + catParam
            }
          }else{
            enterKeywordMessage()
          }
        })
      })()
      </script>
    
  </div>

</div>



  <script>
    new Foundation.LoginRequiredComponent("SearchLogin");
  </script>

  



<div id="LogoandLeaderboard" class="GlobalHeader ContentFullWidth ">
  <div id="header-logo" class="admin">
    
      <div id="logo"><a href="https://www.rochestercitynewspaper.com/" title="CITY News">Rochester City Newspaper</a></div>
    
  </div>
</div>





<script type="text/javascript">
    Event.observe(document, "dom:loaded", function () {
      var yOffset = jQuery('#NavigationHorizontal').offset().top
      jQuery(window).scroll(function(){
        var pos = jQuery(document).scrollTop() - yOffset
        if (pos >= 0) {
          jQuery("#NavigationHorizontal").addClass('sticky')
        } else {
          jQuery("#NavigationHorizontal").removeClass('sticky')
        }
      })
    })
    </script>














  <div id="NavigationHorizontal" class="GlobalHeader ContentFullWidth  ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first" id="NavItem_Magazine">
          <a href="https://issuu.com/roccitynews/docs/august_2022_web"  class="subnav_link" id="SNAVL_Magazine">Magazine</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_News">
          <a href="https://www.rochestercitynewspaper.com/rochester/news-and-opinion/Section?oid=2124539"  class="subnav_link" id="SNAVL_News">News</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Arts">
          <a href="https://www.rochestercitynewspaper.com/rochester/arts-and-entertainment/Section?oid=2124540"  class="subnav_link" id="SNAVL_Arts">Arts</a>
        </li>
        
      
        

        

        

        

        <li class="navCurrent" id="NavItem_Life">
          <a href="https://www.rochestercitynewspaper.com/rochester/life/Section?oid=12795708"  class="subnav_link" id="SNAVL_Life">Life</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Music">
          <a href="https://www.rochestercitynewspaper.com/rochester/music/Section?oid=2124542"  class="subnav_link" id="SNAVL_Music">Music</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_calendar">
          <a href="https://www.rochestercitynewspaper.com/rochester/EventSearch"  class="subnav_link" id="SNAVL_calendar">Calendar</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Guides">
          <a href="https://www.rochestercitynewspaper.com/"  class="subnav_link" id="SNAVL_Guides">Guides</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Crossword">
          <a href="https://www.rochestercitynewspaper.com/rochester/CrosswordPuzzle/Page"  >Crossword</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_About">
          <a href="https://www.rochestercitynewspaper.com/rochester/citychampion/Page"  class="subnav_link" id="SNAVL_About">About</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_WXXI">
          <a href="https://www.wxxi.org/"  class="subnav_link" id="SNAVL_WXXI">WXXI</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_Advertise">
          <a href="https://www.rochestercitynewspaper.com/rochester/Advertisewithus/Page"  >Advertise</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse News</h3>
            <ul class="subnav_content" id="SNAV_News" style="display:none;">
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/news/Category?oid=2124545"  title="">News</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/editors-notebook/Category?oid=10897198"  title="">Editor&#39;s Notebook</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?section=2124539"  title="">News &amp; Opinion Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Music</h3>
            <ul class="subnav_content" id="SNAV_Music" style="display:none;">
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/music-features/Category?oid=2124556"  title="">Music Features</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/classical/Category?oid=2124554"  title="">Classical</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/choice-concerts/Category?oid=2124583"  title="">Choice Concerts</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/music-reviews/Category?oid=2124557"  title="">Music Reviews</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/EventSearch?sortType=title&eventSection=2124770"  title="">Local Music Guide</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/homestage/Category?oid=11779711"  title="">Homestage</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?section=2124542"  title="">Music Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Arts</h3>
            <ul class="subnav_content" id="SNAV_Arts" style="display:none;">
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/art/Category?oid=2124551"  title="">Art</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/comedy/Category?oid=11289421"  title="">Comedy</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/dance/Category?oid=2124799"  title="">Dance</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?category=6131363"  title="">Literature</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/theater/Category?oid=2124552"  title="">Theater</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/revel-in-the-details/Category?oid=12799483"  title="">Revel in the Details</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.artworkroc.com"  title="">art/WORK</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?section=2124540"  title="">Arts &amp; Entertainment Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Calendar</h3>
            <ul class="subnav_content" id="SNAV_calendar" style="display:none;">
          

          

          <li class="searchItem">
            <a href="https://www.rochestercitynewspaper.com/rochester/EventSearch?narrowByDate=Today&sortType=title"  title="">Event Listings</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/choice-events/Category?oid=2124582"  title="">Choice Events</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/choice-concerts/Category?oid=2124583"  title="">Choice Concerts</a>
          </li>
          
        
          

          

          <li class="submitItem">
            <a href="https://www.rochestercitynewspaper.com/rochester/Events/AddEvent"  title="">Submit an Event</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Restaurants</h3>
            <ul class="subnav_content" id="SNAV_Restaurants" style="display:none;">
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/dining-reviews/Category?oid=2124559"  title="">Dining Reviews</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/restaurant-news/Category?oid=2124813"  title="">Restaurant News</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Guides</h3>
            <ul class="subnav_content" id="SNAV_Guides" style="display:none;">
          

          

          <li class="">
            <a href="https://express.adobe.com/page/iUhtuJ688wQNu/"  title="">Hidden Gems: Adventure Guide</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://express.adobe.com/page/F30m8LwnbOCTF/"  title="">TOAST: A Holiday Guide</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://express.adobe.com/page/JXAXG40w5TRRJ/"  title="">Rochester Burger Week</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://express.adobe.com/page/luS07Wcqecrfa/"  title="">Beyond the Fold</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse About</h3>
            <ul class="subnav_content" id="SNAV_About" style="display:none;">
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/AboutUs/Page"  title="">Contact Us</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/citychampion/Page"  title="">Donate</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/where-to-find-city/Content?oid=11274502"  title="">Looking for CITY?</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/homedeliverysignup/Page"  title="">Get Home Delivery</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://mailchi.mp/rochester-citynews.com/newsletters"  title="">Sign up for our Newsletter</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse WXXI</h3>
            <ul class="subnav_content" id="SNAV_WXXI" style="display:none;">
          

          

          <li class="">
            <a href="https://www.wxxinews.org/"  title="">Newsroom</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.wxxi.org/tv"  title="">Television</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.wxxi.org/radio"  title="">Radio</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://thelittle.org/"  title="">The Little</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.wxxi.org/education"  title="">Education</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Life</h3>
            <ul class="subnav_content" id="SNAV_Life" style="display:none;">
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/public-lives/Category?oid=12204813"  title="">Public Lives</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?category=2124813"  title="">Food News</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/culture/Category?oid=2124804"  title="">Culture</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?category=2124559"  title="">Food Reviews</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/movies/Section?oid=2124830"  title="">Movies</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/what-ales-me/Category?oid=12795717"  title="">What Ales Me</a>
          </li>
          
            </ul>
          
        

        

        
        
        
      
    
  </div>


  

  
  
  
    
    

      

      <script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>
    
  
  <!-- true == "true"
         && true == "devel" -->


<!-- End #NavigationHorizontal --><div id="Ad970x90" class="GlobalHeader ContentFullWidth Ad">
  <!-- /1843875/CITY_LEADERBOARD -->
          <div id="div-gpt-ad-city_leaderboard" style="" data-content-type="ad" data-slot="/1843875/CITY_LEADERBOARD" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-city_leaderboard');
                });
              </script>
          </div>
</div>
  </div><!-- end gridHeader -->

  <div id="gridMain">
    <!-- ZoneA -->
    <div id="gridTopRow">
      



  
    <div id="StoryBreadcrumb" class="HomeTopRow ContentFullWidth  life culture">
      <p class="issueInfo ">
        <span class="date">
          
            <a href="https://www.rochestercitynewspaper.com/rochester/IssueArchives?issue=13264290">August 08, 2022</a>
          
        </span>

  			
          <a href="https://www.rochestercitynewspaper.com/rochester/life/Section?oid=12795708">Life</a>
        
        
          &raquo; <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?category=2124804">Culture</a>
        
      </p>
    </div> <!-- end StoryBreadcrumb -->
  





  

  

  
    <div id="StoryHeader" class="HomeTopRow ContentFullWidth   home_feature_newsbreak">
      <div class="storyHead">
        
        <h1 class="headline headline-14966332">CITY Visits...The Puerto Rican Festival of Rochester&nbsp;</h1>        
        
        
          

          <cite class="byline">
            <span class="byAttribute">By</span> <a href="https://www.rochestercitynewspaper.com/author/matt-burkhartt" rel="author">Matt Burkhartt</a> and <a href="https://www.rochestercitynewspaper.com/author/jeremy-moule" rel="author">Jeremy Moule</a>
              
                
                  
                    <span class="twitter"><a href="http://twitter.com/jfmoule" title="jfmoule" target="_blank">@jfmoule</a></span>
               
          </cite>

          

        
      </div>
    </div> <!-- end StoryHeader -->
  











  
  
  
  
  
    
  





<div id="StoryLayout" class="HomeTopRow ContentFullWidth  home_feature newsbreak">

  

    

    









































    
    

    
      
    
    
    
    
      
      

      
              
    

      
     
       
      
      
      
      
    
      <div id="storyBody" class="page1 home_feature newsbreak">
        
      
        

        
        
          <div style="text-align: center;">
                    <b style="font-family: Lato, sans-serif; font-size: 1.375rem;">For the first time since 2020, the Puerto Rican Festival of Rochester returned to Frontier Field. We talked to people reveling in the red, white, and blue-soaked cultural showcase of food, music, and dance from dusk to dark.</b>      
</div>
            
<div style="text-align: center;">
                    <br>
                       
</div>
      <i><div style="text-align: center;">
                    <i style="font-family: Lato, sans-serif; font-size: 1.375rem;">Photos by Matt Burkhartt. Interviews by Jeremy Moule.</i>      
</div></i><br>
       <div class="contentImageCenter" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/rochester/imager/u/original/14966518/janelisediaz.jpg" class="zoomable" rel="contentImg_gal-14966332" title="">                  <img src="https://media1.fdncms.com/rochester/imager/u/blog/14966518/janelisediaz.jpg?cb=1659971292" width="980" height="1469" alt="janelisediaz.jpg" srcset="" />                </a>                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <b>JANELISE DIAZ, 13</b><br>
  ROCHESTER, STUDENT<br>
      <br>
  <b>Is it important to you to show pride in your heritage?</b><br>
      <i>"I like for people to know that I’m Puerto Rican. I like having it [the Puerto Rican flag] around when I come to this type of thing because I feel like I’m a part of it."</i><br>
      <br>
       <div class="contentImageCenter" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/rochester/imager/u/original/14966519/randycampanaro.jpg" class="zoomable" rel="contentImg_gal-14966332" title="">                  <img src="https://media1.fdncms.com/rochester/imager/u/blog/14966519/randycampanaro.jpg?cb=1659971293" width="980" height="1469" alt="randycampanaro.jpg" srcset="" />                </a>                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <b>RANDY CAMPANARO, 45</b><br>
  GATES, FOOD TRUCK CHEF<br>
      <br>
  <b>Do you come to the festival regularly?</b><br>
      <i>"We come to this every year, even if it’s just for a couple of hours one day out of the weekend to come and hang out and be around our people and listen to our music."</i><br>
         <br>
       <div class="contentImageCenter" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/rochester/imager/u/original/14966520/juanramosfigueroa.jpg" class="zoomable" rel="contentImg_gal-14966332" title="">                  <img src="https://media2.fdncms.com/rochester/imager/u/blog/14966520/juanramosfigueroa.jpg?cb=1659971293" width="980" height="1469" alt="juanramosfigueroa.jpg" srcset="" />                </a>                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <b>JUAN RAMOS FIGUEROA, 20</b><br>
      ROCHESTER, CUSTODIAN<br>
      <br>
      <b>What aspects of Puerto Rican culture are important for people to see?</b><br>
      <i>"There’s a wide variety of people here, all colors, and no judging. It’s a free, open space where everyone can be themselves."</i><br>
      <br>
       <div class="contentImageCenter" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/rochester/imager/u/original/14966521/keyravega.jpg" class="zoomable" rel="contentImg_gal-14966332" title="">                  <img src="https://media2.fdncms.com/rochester/imager/u/blog/14966521/keyravega.jpg?cb=1659971293" width="980" height="1469" alt="keyravega.jpg" srcset="" />                </a>                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <b>KEYRA VEGA, 45</b><br>
  GREECE, OFFICE MANAGER<br>
      <br>
      <b>What's appealing about the festival and Puerto Rican culture?</b><br>
      <i>"Everything we’ve got here — we’ve got Spanish food, we’ve got Spanish music, we’ve got people from Puerto Rico, and sometimes I’ll be around here, you can see the people that you haven’t seen for so long. Sometimes they come from Puerto Rico."<br>
      <br></i> <div class="contentImageCenter" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/rochester/imager/u/original/14966522/gerrycinquino.jpg" class="zoomable" rel="contentImg_gal-14966332" title="">                  <img src="https://media1.fdncms.com/rochester/imager/u/blog/14966522/gerrycinquino.jpg?cb=1659971293" width="980" height="1469" alt="gerrycinquino.jpg" srcset="" />                </a>                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <b>GERRY CINQUINO, 63</b><br>
      CLEARMONT, FLORIDA, RETIRED<br>
      <br>
  <b>What brought you to the Puerto Rican Festival?</b><br>
      <i>"My wife is Puerto Rican and we’ve been coming down here. When I was living here we’d come down quite frequently. We’ve been gone a couple of years so we were here visiting our daughter and family and friends."</i><br>
      <br>
       <div class="contentImageCenter" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/rochester/imager/u/original/14966523/josephgiarratino.jpg" class="zoomable" rel="contentImg_gal-14966332" title="">                  <img src="https://media2.fdncms.com/rochester/imager/u/blog/14966523/josephgiarratino.jpg?cb=1659971294" width="980" height="1469" alt="josephgiarratino.jpg" srcset="" />                </a>                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <b>JOSEPH GIARRANTINO, 65</b><br>
  ROCHESTER, RETIRED<br>
      <br>
      <b>What brought you down to the festival?</b><br>
      <i>"I just like to see the community get together and Rochester come back to life. It’s getting a good name again."<br>
      <br></i> <div class="contentImageCenter" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/rochester/imager/u/original/14966525/richierosa.jpg" class="zoomable" rel="contentImg_gal-14966332" title="">                  <img src="https://media2.fdncms.com/rochester/imager/u/blog/14966525/richierosa.jpg?cb=1659971294" width="980" height="1469" alt="richierosa.jpg" srcset="" />                </a>                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <b>RICHIE ROSA, 48</b><br>
      ROCHESTER, TATTOO ARTIST<br>
      <br>
  <b>What would you tell someone to&nbsp; get them to come to the festival?</b><br>
      <i>"We’ve always got the flavor. We’ve got the soul."<br>
      <br></i> <div class="contentImageCenter" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/rochester/imager/u/original/14966526/jasonrivera.jpg" class="zoomable" rel="contentImg_gal-14966332" title="">                  <img src="https://media1.fdncms.com/rochester/imager/u/blog/14966526/jasonrivera.jpg?cb=1659971294" width="980" height="1469" alt="jasonrivera.jpg" srcset="" />                </a>                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <b>JASON RIVERA, 41</b><br>
  ROCHESTER, TIN KNOCKER<br>
      <br>
  <b>Do you think this is a valuable event?</b><br>
      <i>"We need a lot more stuff like this, a good spot where everybody can go and be safe."<br>
      <br></i> <div class="contentImageCenter" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/rochester/imager/u/original/14966527/steventejeda.jpg" class="zoomable" rel="contentImg_gal-14966332" title="">                  <img src="https://media2.fdncms.com/rochester/imager/u/blog/14966527/steventejeda.jpg?cb=1659971294" width="980" height="1469" alt="steventejeda.jpg" srcset="" />                </a>                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <b>STEVEN TEJEDA, 18</b><br>
  SPENCERPORT, CASHIER<br>
      <br>
      <b>Was it important to you to learn Latin dance?</b><br>
      <i>"I dance so much because growing up I had trouble speaking Spanish and by learning how to dance I could still communicate with others and join in on the fun, join in on the party, you know."<br>
      <br></i> <div class="contentImageCenter" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/rochester/imager/u/original/14966528/rosemaryortiz.jpg" class="zoomable" rel="contentImg_gal-14966332" title="">                  <img src="https://media2.fdncms.com/rochester/imager/u/blog/14966528/rosemaryortiz.jpg?cb=1659971294" width="980" height="1469" alt="rosemaryortiz.jpg" srcset="" />                </a>                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <b>ROSEMARY ORTIZ, 62</b><br>
  ROCHESTER, PARAPROFESSIONAL<br>
      <br>
 <b>A lot of people are wearing the Puerto Rican flag.</b><br>
      <i>"In Puerto Rico, everybody’s proud. If you go to a concert in Puerto Rico everybody’s dressed like me. Nobody has brown and yellow and green and blue. No.  You dress red, white, and blue."<br>
      <br></i> <div class="contentImageCenter" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/rochester/imager/u/original/14966529/jimmyrodriguez.jpg" class="zoomable" rel="contentImg_gal-14966332" title="">                  <img src="https://media2.fdncms.com/rochester/imager/u/blog/14966529/jimmyrodriguez.jpg?cb=1659971294" width="980" height="1469" alt="jimmyrodriguez.jpg" srcset="" />                </a>                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <b>JIMMY RODRIGUEZ, 33</b><br>
      ROCHESTER, MACHINE OPERATOR<br>
      <br>
  <b>Does anything in particular draw you to the festival?</b><br>
      <i>"Every year I just come down to see my people here, my friends and my family."<br>
      <br></i> <div class="contentImageCenter" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/rochester/imager/u/original/14966530/francishare_1_.jpg" class="zoomable" rel="contentImg_gal-14966332" title="">                  <img src="https://media1.fdncms.com/rochester/imager/u/blog/14966530/francishare_1_.jpg?cb=1659971295" width="980" height="1469" alt="francishare_1_.jpg" srcset="" />                </a>                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>  <b>FRANCIS HARE, 73</b><br>
      PITTSFORD, TEACHING ARTIST<br>
      <br>
      <b>You say you danced several styles but how does dancing salsa, bachata, and other Latin styles feel?<br></b><i>"It’s kind of a gut thing because once you start getting that swing and you’re dancing with that partner, you’re in a different kind of state of mind about it."</i><br>
      <br>
            
<div style="text-align: center;">
                    <b style="font-family: Lato, sans-serif; font-size: 1.375rem;">Want CITY to visit you or a place you like to go?</b>      
</div>
            
<div style="text-align: center;">
                    <span style="font-family: Lato, sans-serif; font-size: 1.375rem;"><b>Let us know at</b></span><b style="font-weight: bold; font-family: Lato, sans-serif; font-size: 1.375rem;"> <a href="mailto:feedback@rochester-citynews.com">feedback@rochester-citynews.com</a>.</b>      
</div>
       <div class="contentImageCenter" style="overflow:hidden;">                              <span class="clicktozoom imageHasURL">click image</span>                <a href="https://www.rochestercitynewspaper.com/rochester/citychampion/Page" target="_self" title="champion-story-banner.gif">                  <img src="https://media1.fdncms.com/rochester/imager/u/blog/14966531/champion-story-banner.gif?cb=1659971295" width="980" height="305" alt="champion-story-banner.gif" srcset="" />                </a>                                                                                                           <ul style="width:980px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>
        

        
        

        
        
      </div>
    

  
  
</div> <!-- end StoryLayout -->








































  

  

  <div class="HomeTopRow ContentFullWidth CommentsComponent   uk-root fdn-margin-vert DisqusComments comp-shell-disquscomments" data-component-id="DisqusComments">
    

    <div id="disqus_thread"></div>
    <script>
      var disqus_config = function () {
        this.page.url = "https:\/\/www.rochestercitynewspaper.com\/rochester\/city-visits-the-puerto-rican-festival-of-rochester\/Content?oid=14966332";
        this.page.identifier = "rochester:14966332";
      };

      (function() {
        var d = document, s = d.createElement('script');
        s.src = "https://https-roccitynews-com.disqus.com/embed.js";
        s.setAttribute('data-timestamp', +new Date());
        (d.head || d.body).appendChild(s);
      })();
    </script>
    <noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
  </div>





  
  















  
  
  

  
  
  

  
 
  




  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="HomeTopRow ContentFullWidth ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:16%; height: 20px; float:left;">
        <fb:like href="https://www.rochestercitynewspaper.com/rochester/city-visits-the-puerto-rican-festival-of-rochester/Content?oid=14966332" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:16%; height: 20px; float:left;"><a href="https://twitter.com/share?url=https%3A//www.rochestercitynewspaper.com/rochester/city-visits-the-puerto-rican-festival-of-rochester/Content%3Foid%3D14966332&text=CITY%20Visits...The%20Puerto%20Rican%20Festival%20of%20Rochester" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:16%; height: 20px; float:left;">


  

  

  

  <a href="https://pinterest.com/pin/create/button/?description=CITY%20Visits...The%20Puerto%20Rican%20Festival%20of%20Rochester&amp;media=https%3A%2F%2Fmedia2.fdncms.com%2Frochester%2Fimager%2Fu%2Fslideshow%2F14966532%2Fpr_fest_teaser.png&amp;url=https%3A%2F%2Fwww.rochestercitynewspaper.com%2Frochester%2Fcity-visits-the-puerto-rican-festival-of-rochester%2FContent%3Foid%3D14966332" class="pin-it-button" count-layout="none">Pin It</a>
  <script>
  Foundation.documentReady.then(function () {
    new Foundation.Script("https://assets.pinterest.com/js/pinit.js", true);
  })
  </script>

</div> <div class="l0" style="width:16%; height: 20px; float:left;">

<a class="emailAction" title="." href="https://posting.rochestercitynewspaper.com/rochester/Tools/EmailFriend?oid=14966332" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">.</a>

</div> <div class="l0" style="width:16%; height: 20px; float:left;">


  <a class="toggleActivator saveAction requiresLogin" title="My Favorites" href="https://posting.rochestercitynewspaper.com/rochester/Profile/MyFavorites?add=14966332">
    Favorites
  </a>
  <div class="togglePanel" data-toolsoid="14966332" data-toolsajaxmacro="addObject" style="display:none">
    <div class="loading">Saving&hellip;</div>
    <div class="ajaxUpdater" style="display:none"></div>
  </div>


</div> <div class="l0 last" style="width:16%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=xa-503d61bf5addb3a2" addthis:url="https://www.rochestercitynewspaper.com/rochester/city-visits-the-puerto-rican-festival-of-rochester/Content?oid=14966332" addthis:title="CITY Visits...The Puerto Rican Festival of Rochester" addthis:description="The Puerto Rican Festival returned to Frontier Field. We talked to people reveling in the red, white, and blue-soaked showcase of food, music, and dance." class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-503d61bf5addb3a2", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  




  <div id="ArchiveLink" class="HomeTopRow ContentFullWidth ">
    <p class="moreArticles">
      
        <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?category=2124804">More Culture &raquo;</a>
      
      
    </p>
  </div> <!-- end ArchiveLink -->


    </div>   
    
  <div id="gridLeftColumn">    
      
    <!-- Zone B -->
      <div id="leftColumnTopLeft">
        
      </div> 
      
      <!-- Zone C -->
      <div id="leftColumnTopRight">
        
      </div>
        
      <div class="clear"></div>
   
      <!-- Zone D -->
      <div id="leftColumnCenter">
        










  
  

  
  



    
    
    
    



















  

  

  
  

  
    
  

  















  
  
  

  <!-- UIkit CSS -->
  <link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.css?cb=73d58e45a152a8366583b5d4cdd27aaf" />

  <!-- UIkit JS -->
  <script src="/fdn-system/assets/pub/scripts/uikit.min.js?cb=73d58e45a152a8366583b5d4cdd27aaf"></script>
  <script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.min.js?cb=73d58e45a152a8366583b5d4cdd27aaf"></script>


  

  <style>
    @media (min-width: 640px){
      div[id] .uk-child-width-1-3\@exs > * {
         width: calc(100% * 1 / 3.001);
      } 
    }
    #gridMainColumn .uk-width-1-2\@es {
      width: 50%;
    }

    #gridMainColumn .uk-child-width-auto\@exs > * {
      width: auto;
    }
    
    .uk-root {
      font-size: 14px;
    }
  </style>



















 
  <div id="StoryTags" class="HomeLeftColumn ContentFullWidth ">
    <p class="tags">Tags: <a href="/rochester/ArticleArchives?category=2124804" rel="tag">Culture</a></p>          
  </div> <!-- end StoryTags -->




<!-- Custom Macros -->
  <script>
  (function() {
  if(document.getElementById('commitchange-script')) return;
  var npo = 5423;
  var script = document.createElement('script');
  var first = document.getElementsByTagName('script')[0];
  script.setAttribute('data-npo-id', npo);
  script.id = 'commitchange-script';
  script.src = 'https://us.commitchange.com/js/donate-button.v2.js';
  first.parentNode.insertBefore(script, first);
  })();
  </script>
<!-- Custom Macros -->
  <a data-amounts='5.85,15.85,58.50,585.00,Other' class='commitchange-donate' data-custom='' data-hide-dedication=''></a>























  

  

  
    <div id="MorebyThisAuthorWrapper" class="HomeLeftColumn ContentFullWidth Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="HomeLeftColumn ContentFullWidth ">
            <h3><span class="headingText">More by Jeremy Moule</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/monroe-countys-oldest-building-to-get-a-checkup/Content?oid=14949853">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/14950018/microsoftteams-image_88_.png"
             alt="Monroe County&rsquo;s oldest building to get a checkup"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/monroe-countys-oldest-building-to-get-a-checkup/Content?oid=14949853">Monroe County’s oldest building to get a checkup</a>
    </h4>
    <div class="date"> Aug  4, 2022 </div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/democratic-lawsuit-seeks-to-keep-vanbrederode-off-of-independence-line/Content?oid=14895181">
        <img src="https://media2.fdncms.com/rochester/imager/u/review/14895185/vb2_1.jpg"
             alt="Democratic lawsuit seeks to keep VanBrederode off of Independence line"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/democratic-lawsuit-seeks-to-keep-vanbrederode-off-of-independence-line/Content?oid=14895181">Democratic lawsuit seeks to keep VanBrederode off of Independence line</a>
    </h4>
    <div class="date"> Jul 22, 2022 </div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/brighton-renewable-power-program-on-pause-after-contractor-defaults/Content?oid=14859719">
        <img src="https://media2.fdncms.com/rochester/imager/u/review/14859723/news3-1.jpg"
             alt="Brighton renewable power program on pause after contractor defaults"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/brighton-renewable-power-program-on-pause-after-contractor-defaults/Content?oid=14859719">Brighton renewable power program on pause after contractor defaults</a>
    </h4>
    <div class="date"> Jul 13, 2022 </div>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?author=2124656" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
      
      
          <div id="MorebyThisAuthor" class="HomeLeftColumn ContentFullWidth ">
            <h3><span class="headingText">More by Matt Burkhartt</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/city-visitsthe-harborfest-classic-car-show/Content?oid=14783961">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/14783965/charlottecarshow_mb31_06182022.jpg"
             alt="CITY Visits...The Harborfest Classic Car Show"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/city-visitsthe-harborfest-classic-car-show/Content?oid=14783961">CITY Visits...The Harborfest Classic Car Show</a>
    </h4>
    <div class="date"> Jun 24, 2022 </div>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?author=2256244" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  










  
  
      <div id="LatestInCategory" class="HomeLeftColumn ContentFullWidth ">
        <h3 class="latestculture"><span class="headingText">Latest in Culture</span></h3>
        <ul class="moduleList ui list grouped expanded">
    
    
    <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/city-visits-the-rochester-pride-parade/Content?oid=14912381">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/14912394/ginger_kaikai2.jpg"
             alt="CITY Visits...The Rochester Pride Parade"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/city-visits-the-rochester-pride-parade/Content?oid=14912381">CITY Visits...The Rochester Pride Parade</a>
    </h4>
    <div class="date"> Jul 26, 2022 </div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/the-historic-avon-park-theater-reopens-after-years-of-neglect/Content?oid=14908256">
        <img src="https://media2.fdncms.com/rochester/imager/u/review/14908262/avon_teaser.jpg"
             alt="The historic Avon Park Theater reopens after years of neglect"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/the-historic-avon-park-theater-reopens-after-years-of-neglect/Content?oid=14908256">The historic Avon Park Theater reopens after years of neglect</a>
    </h4>
    <div class="date"> Jul 25, 2022 </div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/weekly-planner-july-11-17-whats-happening-in-arts-music-and-life/Content?oid=14851973">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/14851979/teaser.jpg"
             alt="Weekly Planner July 11 - 17: What&#39;s Happening in Arts, Music, and Life"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/weekly-planner-july-11-17-whats-happening-in-arts-music-and-life/Content?oid=14851973">Weekly Planner July 11 - 17: What's Happening in Arts, Music, and Life</a>
    </h4>
    <div class="date"> Jul 11, 2022 </div>
  </li>
    
  
        
            <li class="l0 storyItem more">
              <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?category=2124804" class="more">More &raquo;</a>
            </li>
          </ul>
        
      </div>
    










  

  
    
        <div id="PeopleWhoLiked" class="HomeLeftColumn ContentFullWidth ">
          <h3><span class="headingText">Readers also liked&hellip;</span></h3>
          <ul>
      
      
      
      <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/schittin-good-coffee-good-to-the-last-plop/Content?oid=13126767">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/13127500/teaser.jpg"
             alt="Schittin Good Coffee: Good to the last plop"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/schittin-good-coffee-good-to-the-last-plop/Content?oid=13126767">Schittin Good Coffee: Good to the last plop</a>
    </h4>
    <div class="date"> Apr 30, 2021 </div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/black-deaf-american-sign-language-eager-to-be-heard/Content?oid=13372732">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/13372900/joseph_hill.jpg"
             alt="Black, deaf, and eager to be heard"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/black-deaf-american-sign-language-eager-to-be-heard/Content?oid=13372732">Black, deaf, and eager to be heard</a>
    </h4>
    <div class="date"> Jun 29, 2021 </div>
  </li>
      
      
    
          </ul>
        </div>
      
               

      </div>
      
      <!-- Zone I -->
      <div id="leftColumnBtmLeft">
        
      </div> 

      <!-- Zone J -->
      <div id="leftColumnBtmRight">
       
      </div> 
      
      <div class="clear"></div>
      <!-- End gridLeftColumn --></div> 
      
      
    <div id="gridRightSidebar">
      <!-- Zone E -->
        <div id="homeSidebarTop">
        




  

  

  
  

  
  

  
     

     

  
  

  
  


  

  
  
  


  

  



  

  

  
  



<div id="BoxAd1" class="HomeSidebar ContentFullWidth Ad MediumRectangle">
  <!-- /1843875/CITY_MED_RECT_1 -->
          <div id="div-gpt-ad-city_med_rect_1" style="" data-content-type="ad" data-slot="/1843875/CITY_MED_RECT_1" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-city_med_rect_1');
                });
              </script>
          </div>
</div><div id="Ad_300x100_2" class="HomeSidebar ContentFullWidth ShortRectangle Ad">
  <!-- /1843875/CITY_Sitewide_DD_Ad -->
          <div id="div-gpt-ad-city_sitewide_dd_ad" style="" data-content-type="ad" data-slot="/1843875/CITY_Sitewide_DD_Ad" data-output="asynchronous" data-width="300" data-height="100">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-city_sitewide_dd_ad');
                });
              </script>
          </div>
</div>
<div id="BoxAd2" class="HomeSidebar ContentFullWidth Ad MediumRectangle">
  <!-- /1843875/CITY_MED_RECT_2 -->
          <div id="div-gpt-ad-city_med_rect_2" style="" data-content-type="ad" data-slot="/1843875/CITY_MED_RECT_2" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-city_med_rect_2');
                });
              </script>
          </div>
</div><div id="Ad_300x100_1" class="HomeSidebar ContentFullWidth ShortRectangle Ad">
  <!-- /1843875/CITY_Sitewide_UR_Ad -->
          <div id="div-gpt-ad-city_sitewide_ur_ad" style="" data-content-type="ad" data-slot="/1843875/CITY_Sitewide_UR_Ad" data-output="asynchronous" data-width="300" data-height="100">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-city_sitewide_ur_ad');
                });
              </script>
          </div>
</div>







  
  
      <div id="LatestInCategory" class="HomeSidebar ContentFullWidth ">
        <h3 class="latestculture"><span class="headingText">Latest in Culture</span></h3>
        <ul class="moduleList ui list grouped expanded">
    
    
    <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/city-visits-the-rochester-pride-parade/Content?oid=14912381">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/14912394/ginger_kaikai2.jpg"
             alt="CITY Visits...The Rochester Pride Parade"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/city-visits-the-rochester-pride-parade/Content?oid=14912381">CITY Visits...The Rochester Pride Parade</a>
    </h4>
    <div class="date"> Jul 26, 2022 </div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/the-historic-avon-park-theater-reopens-after-years-of-neglect/Content?oid=14908256">
        <img src="https://media2.fdncms.com/rochester/imager/u/review/14908262/avon_teaser.jpg"
             alt="The historic Avon Park Theater reopens after years of neglect"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/the-historic-avon-park-theater-reopens-after-years-of-neglect/Content?oid=14908256">The historic Avon Park Theater reopens after years of neglect</a>
    </h4>
    <div class="date"> Jul 25, 2022 </div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/weekly-planner-july-11-17-whats-happening-in-arts-music-and-life/Content?oid=14851973">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/14851979/teaser.jpg"
             alt="Weekly Planner July 11 - 17: What&#39;s Happening in Arts, Music, and Life"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/weekly-planner-july-11-17-whats-happening-in-arts-music-and-life/Content?oid=14851973">Weekly Planner July 11 - 17: What's Happening in Arts, Music, and Life</a>
    </h4>
    <div class="date"> Jul 11, 2022 </div>
  </li>
    
  
        
            <li class="l0 storyItem more">
              <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?category=2124804" class="more">More &raquo;</a>
            </li>
          </ul>
        
      </div>
    










  

  

  
    <div id="MorebyThisAuthorWrapper" class="HomeSidebar ContentFullWidth Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="HomeSidebar ContentFullWidth ">
            <h3><span class="headingText">More by Jeremy Moule</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/monroe-countys-oldest-building-to-get-a-checkup/Content?oid=14949853">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/14950018/microsoftteams-image_88_.png"
             alt="Monroe County&rsquo;s oldest building to get a checkup"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/monroe-countys-oldest-building-to-get-a-checkup/Content?oid=14949853">Monroe County’s oldest building to get a checkup</a>
    </h4>
    <div class="date"> Aug  4, 2022 </div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/democratic-lawsuit-seeks-to-keep-vanbrederode-off-of-independence-line/Content?oid=14895181">
        <img src="https://media2.fdncms.com/rochester/imager/u/review/14895185/vb2_1.jpg"
             alt="Democratic lawsuit seeks to keep VanBrederode off of Independence line"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/democratic-lawsuit-seeks-to-keep-vanbrederode-off-of-independence-line/Content?oid=14895181">Democratic lawsuit seeks to keep VanBrederode off of Independence line</a>
    </h4>
    <div class="date"> Jul 22, 2022 </div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/brighton-renewable-power-program-on-pause-after-contractor-defaults/Content?oid=14859719">
        <img src="https://media2.fdncms.com/rochester/imager/u/review/14859723/news3-1.jpg"
             alt="Brighton renewable power program on pause after contractor defaults"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/brighton-renewable-power-program-on-pause-after-contractor-defaults/Content?oid=14859719">Brighton renewable power program on pause after contractor defaults</a>
    </h4>
    <div class="date"> Jul 13, 2022 </div>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?author=2124656" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
      
      
          <div id="MorebyThisAuthor" class="HomeSidebar ContentFullWidth ">
            <h3><span class="headingText">More by Matt Burkhartt</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/city-visitsthe-harborfest-classic-car-show/Content?oid=14783961">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/14783965/charlottecarshow_mb31_06182022.jpg"
             alt="CITY Visits...The Harborfest Classic Car Show"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/city-visitsthe-harborfest-classic-car-show/Content?oid=14783961">CITY Visits...The Harborfest Classic Car Show</a>
    </h4>
    <div class="date"> Jun 24, 2022 </div>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?author=2256244" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  
























<div id="EventChooser" class="HomeSidebar ContentFullWidth ">
  <h3>Browse Listings</h3>

  <div class="tabs">
    <div class="tabCurrent tabLeft"><a href="#">Events</a></div>
    <div class="tabBack tabRight"><a href="#">Music</a></div>
  </div>
  <div class="clear"><!-- clear --></div>


  
  

  <div id="calendarBody-events" class="eventSearchBody" >
    <form name="eventSearchForm" method="get" action="https://www.rochestercitynewspaper.com/rochester/EventSearch">
      <select name="narrowByDate">
    <option value="">-All Dates-</option>
    
    
      
      
        
        
          <option value="2022-08-08" selected="selected">Monday, August  8</option>
        
      
        
        
          <option value="2022-08-09">Tuesday, August  9</option>
        
      
        
        
          <option value="2022-08-10">Wednesday, August 10</option>
        
      
        
        
          <option value="2022-08-11">Thursday, August 11</option>
        
      
        
        
          <option value="2022-08-12">Friday, August 12</option>
        
      
        
        
          <option value="2022-08-13">Saturday, August 13</option>
        
      
        
        
          <option value="2022-08-14">Sunday, August 14</option>
        
      
        
        
          <option value="2022-08-15">Monday, August 15</option>
        
      
        
        
          <option value="2022-08-16">Tuesday, August 16</option>
        
      
        
        
          <option value="2022-08-17">Wednesday, August 17</option>
        
      
        
        
          <option value="2022-08-18">Thursday, August 18</option>
        
      
        
        
          <option value="2022-08-19">Friday, August 19</option>
        
      
        
        
          <option value="2022-08-20">Saturday, August 20</option>
        
      
        
        
          <option value="2022-08-21">Sunday, August 21</option>
        
      
        
        
          <option value="2022-08-22">Monday, August 22</option>
        
      
        
        
          <option value="2022-08-23">Tuesday, August 23</option>
        
      
        
        
          <option value="2022-08-24">Wednesday, August 24</option>
        
      
        
        
          <option value="2022-08-25">Thursday, August 25</option>
        
      
        
        
          <option value="2022-08-26">Friday, August 26</option>
        
      
        
        
          <option value="2022-08-27">Saturday, August 27</option>
        
      
        
        
          <option value="2022-08-28">Sunday, August 28</option>
        
      
        
        
          <option value="2022-08-29">Monday, August 29</option>
        
      
        
        
          <option value="2022-08-30">Tuesday, August 30</option>
        
      
        
        
          <option value="2022-08-31">Wednesday, August 31</option>
        
      
        
        
          <option value="2022-09-01">Thursday, September  1</option>
        
      
        
        
          <option value="2022-09-02">Friday, September  2</option>
        
      
        
        
          <option value="2022-09-03">Saturday, September  3</option>
        
      
        
        
          <option value="2022-09-04">Sunday, September  4</option>
        
      
        
        
          <option value="2022-09-05">Monday, September  5</option>
        
      
        
        
          <option value="2022-09-06">Tuesday, September  6</option>
        
      
        
        
          <option value="2022-09-07">Wednesday, September  7</option>
        
      
    
  </select>

      <select name="eventCategory">
        <option value="">-All Categories-</option>
        
          
            <option value="11549839" >*ONLINE</option>
          
          
            <option value="11591202" >&nbsp;&nbsp;Virtual Event</option>
          
        
          
            <option value="2124768" >LIFE</option>
          
          
            <option value="2924836" >&nbsp;&nbsp;Activism</option>
          
        
          
          
            <option value="11352412" >&nbsp;&nbsp;Black History</option>
          
        
          
          
            <option value="2390970" >&nbsp;&nbsp;Call for Participants</option>
          
        
          
          
            <option value="12142297" >&nbsp;&nbsp;Classes</option>
          
        
          
          
            <option value="14276575" >&nbsp;&nbsp;Culinary</option>
          
        
          
          
            <option value="9325826" >&nbsp;&nbsp;Dr. Martin Luther King, Jr. Remembrance</option>
          
        
          
          
            <option value="10190919" >&nbsp;&nbsp;Earth Day</option>
          
        
          
          
            <option value="2124776" >&nbsp;&nbsp;Festivals</option>
          
        
          
          
            <option value="5465873" >&nbsp;&nbsp;Frederick Douglass</option>
          
        
          
          
            <option value="6400527" >&nbsp;&nbsp;Halloween</option>
          
        
          
          
            <option value="2474372" >&nbsp;&nbsp;Holiday</option>
          
        
          
          
            <option value="13231452" >&nbsp;&nbsp;Juneteenth</option>
          
        
          
          
            <option value="2124777" >&nbsp;&nbsp;Kids Events</option>
          
        
          
          
            <option value="12142853" >&nbsp;&nbsp;Kids Exhibits</option>
          
        
          
          
            <option value="2124782" >&nbsp;&nbsp;Lectures</option>
          
        
          
          
            <option value="12127699" >&nbsp;&nbsp;Literary Events &amp; Discussions</option>
          
        
          
          
            <option value="2392843" >&nbsp;&nbsp;Meetings</option>
          
        
          
          
            <option value="8972602" >&nbsp;&nbsp;New Year&#39;s Eve</option>
          
        
          
          
            <option value="2124778" >&nbsp;&nbsp;Recreation</option>
          
        
          
          
            <option value="2124781" >&nbsp;&nbsp;Special Events</option>
          
        
          
          
            <option value="2124780" >&nbsp;&nbsp;Sports</option>
          
        
          
          
            <option value="2124784" >&nbsp;&nbsp;Workshops</option>
          
        
          
            <option value="9154215" >NEW YEAR&#39;S EVE / DAY</option>
          
          
            <option value="9154216" >&nbsp;&nbsp;Family</option>
          
        
          
          
            <option value="9154281" >&nbsp;&nbsp;Laughs</option>
          
        
          
          
            <option value="9154282" >&nbsp;&nbsp;On Screen</option>
          
        
          
          
            <option value="9154414" >&nbsp;&nbsp;Outdoors</option>
          
        
          
          
            <option value="9154283" >&nbsp;&nbsp;Revelry</option>
          
        
          
            <option value="2124696" >VISUAL &amp; PERFORMING ARTS</option>
          
          
            <option value="2124773" >&nbsp;&nbsp;Art Events</option>
          
        
          
          
            <option value="2124771" >&nbsp;&nbsp;Art Exhibits</option>
          
        
          
          
            <option value="2124772" >&nbsp;&nbsp;Call for Artists</option>
          
        
          
          
            <option value="2131975" >&nbsp;&nbsp;Comedy</option>
          
        
          
          
            <option value="2124774" >&nbsp;&nbsp;Dance Events</option>
          
        
          
          
            <option value="2457927" >&nbsp;&nbsp;Film</option>
          
        
          
          
            <option value="2124783" >&nbsp;&nbsp;Readings &amp; Spoken Word</option>
          
        
          
          
            <option value="2124775" >&nbsp;&nbsp;Theater</option>
          
        
          
          
            <option value="2136681" >&nbsp;&nbsp;Theater Audition</option>
          
        
      </select>

      <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="2134278" >CITY OF ROCHESTER</option>
        
        <option value="2229831" >&nbsp;&nbsp;College Town</option>
      
        
        <option value="2124863" >&nbsp;&nbsp;Downtown</option>
      
        
        <option value="2134282" >&nbsp;&nbsp;19th Ward</option>
      
        
        <option value="2134285" >&nbsp;&nbsp;Alphabet Streets</option>
      
        
        <option value="2134286" >&nbsp;&nbsp;Beechwood</option>
      
        
        <option value="2134287" >&nbsp;&nbsp;Brown Square</option>
      
        
        <option value="2134288" >&nbsp;&nbsp;Browncroft</option>
      
        
        <option value="2134289" >&nbsp;&nbsp;Bull&#39;s Head</option>
      
        
        <option value="2134291" >&nbsp;&nbsp;COTS</option>
      
        
        <option value="2134292" >&nbsp;&nbsp;Charlotte</option>
      
        
        <option value="2134293" >&nbsp;&nbsp;Cobbs Hill</option>
      
        
        <option value="2134294" >&nbsp;&nbsp;Corn Hill</option>
      
        
        <option value="2134295" >&nbsp;&nbsp;East Avenue</option>
      
        
        <option value="2134296" >&nbsp;&nbsp;East End</option>
      
        
        <option value="2134297" >&nbsp;&nbsp;Edgerton</option>
      
        
        <option value="2134298" >&nbsp;&nbsp;Genesee-Jefferson</option>
      
        
        <option value="2134299" >&nbsp;&nbsp;Group 14621</option>
      
        
        <option value="2134300" >&nbsp;&nbsp;Grove Place</option>
      
        
        <option value="2134301" >&nbsp;&nbsp;High Falls</option>
      
        
        <option value="2134302" >&nbsp;&nbsp;Highland Park</option>
      
        
        <option value="2134303" >&nbsp;&nbsp;Homestead Heights</option>
      
        
        <option value="2134304" >&nbsp;&nbsp;JOSANA</option>
      
        
        <option value="2134323" >&nbsp;&nbsp;Lyell-Otis</option>
      
        
        <option value="2134324" >&nbsp;&nbsp;Maplewood</option>
      
        
        <option value="2134325" >&nbsp;&nbsp;Marketview Heights</option>
      
        
        <option value="2134327" >&nbsp;&nbsp;Monroe Village</option>
      
        
        <option value="2125238" >&nbsp;&nbsp;Mount Hope</option>
      
        
        <option value="2124698" >&nbsp;&nbsp;Neighborhood of the Arts</option>
      
        
        <option value="2134329" >&nbsp;&nbsp;North Winton Village</option>
      
        
        <option value="2134330" >&nbsp;&nbsp;Northland-Lyceum</option>
      
        
        <option value="2125223" >&nbsp;&nbsp;Park Avenue</option>
      
        
        <option value="2134331" >&nbsp;&nbsp;Pearl-Meigs-Monroe</option>
      
        
        <option value="2134332" >&nbsp;&nbsp;Plymouth-Exchange</option>
      
        
        <option value="12606013" >&nbsp;&nbsp;Seabreeze</option>
      
        
        <option value="2134333" >&nbsp;&nbsp;South Wedge</option>
      
        
        <option value="2134343" >&nbsp;&nbsp;St. Paul Quarter</option>
      
        
        <option value="2134334" >&nbsp;&nbsp;Susan B. Anthony</option>
      
        
        <option value="2134336" >&nbsp;&nbsp;Swillburg</option>
      
        
        <option value="2134337" >&nbsp;&nbsp;U.N.I.T.</option>
      
        
        <option value="2134338" >&nbsp;&nbsp;Upper Falls</option>
      
        
        <option value="2134339" >&nbsp;&nbsp;Upper Monroe Avenue</option>
      
        
        <option value="2134340" >&nbsp;&nbsp;Upper Mount Hope</option>
      
        
        <option value="2134341" >&nbsp;&nbsp;Wadsworth Square</option>
      
        
        <option value="2216396" >&nbsp;&nbsp;Laurelton</option>
      
        
          <option value="2134317" >GREATER ROCHESTER</option>
        
        <option value="2131964" >&nbsp;&nbsp;Brighton</option>
      
        
        <option value="2125582" >&nbsp;&nbsp;Brockport</option>
      
        
        <option value="2136431" >&nbsp;&nbsp;Bushnell&#39;s Basin</option>
      
        
        <option value="2134250" >&nbsp;&nbsp;Chili</option>
      
        
        <option value="2134261" >&nbsp;&nbsp;Churchville</option>
      
        
        <option value="2125260" >&nbsp;&nbsp;East Rochester</option>
      
        
        <option value="2125282" >&nbsp;&nbsp;Fairport</option>
      
        
        <option value="2125274" >&nbsp;&nbsp;Gates</option>
      
        
        <option value="2134080" >&nbsp;&nbsp;Greece</option>
      
        
        <option value="2134255" >&nbsp;&nbsp;Hamlin</option>
      
        
        <option value="2125267" >&nbsp;&nbsp;Henrietta</option>
      
        
        <option value="2125298" >&nbsp;&nbsp;Hilton</option>
      
        
        <option value="2125347" >&nbsp;&nbsp;Honeoye Falls</option>
      
        
        <option value="2125731" >&nbsp;&nbsp;Irondequoit</option>
      
        
        <option value="2134267" >&nbsp;&nbsp;Mendon</option>
      
        
        <option value="2138341" >&nbsp;&nbsp;North Chili</option>
      
        
        <option value="2134257" >&nbsp;&nbsp;Ogden</option>
      
        
        <option value="2125270" >&nbsp;&nbsp;Park Point</option>
      
        
        <option value="2131978" >&nbsp;&nbsp;Penfield</option>
      
        
        <option value="2125579" >&nbsp;&nbsp;Perinton</option>
      
        
        <option value="2125244" >&nbsp;&nbsp;Pittsford</option>
      
        
        <option value="2134266" >&nbsp;&nbsp;Rush</option>
      
        
        <option value="2125783" >&nbsp;&nbsp;Scottsville</option>
      
        
        <option value="2134258" >&nbsp;&nbsp;Spencerport</option>
      
        
        <option value="2134275" >&nbsp;&nbsp;Sweden</option>
      
        
        <option value="2125277" >&nbsp;&nbsp;Webster</option>
      
        
        <option value="2134272" >&nbsp;&nbsp;Wheatland</option>
      
        
          <option value="13672859" >ROCHESTER REGION</option>
        
        <option value="2184747" >&nbsp;&nbsp;Albion</option>
      
        
        <option value="2142743" >&nbsp;&nbsp;Alton</option>
      
        
        <option value="2134491" >&nbsp;&nbsp;Auburn</option>
      
        
        <option value="2201937" >&nbsp;&nbsp;Aurora</option>
      
        
        <option value="2161507" >&nbsp;&nbsp;Avon</option>
      
        
        <option value="2131961" >&nbsp;&nbsp;Batavia</option>
      
        
        <option value="11064499" >&nbsp;&nbsp;Bloomfield</option>
      
        
        <option value="4446507" >&nbsp;&nbsp;Caledonia</option>
      
        
        <option value="2125199" >&nbsp;&nbsp;Canandaigua</option>
      
        
        <option value="2216252" >&nbsp;&nbsp;Clifton Springs</option>
      
        
        <option value="2250745" >&nbsp;&nbsp;Corning</option>
      
        
        <option value="2125263" >&nbsp;&nbsp;Darien</option>
      
        
        <option value="2136578" >&nbsp;&nbsp;Farmington</option>
      
        
        <option value="2139668" >&nbsp;&nbsp;Geneseo</option>
      
        
        <option value="2125585" >&nbsp;&nbsp;Geneva</option>
      
        
        <option value="14393150" >&nbsp;&nbsp;Hemlock</option>
      
        
        <option value="2227154" >&nbsp;&nbsp;Holley</option>
      
        
        <option value="2331864" >&nbsp;&nbsp;Honeoye</option>
      
        
        <option value="2138112" >&nbsp;&nbsp;Interlaken</option>
      
        
        <option value="2125230" >&nbsp;&nbsp;Letchworth</option>
      
        
        <option value="2141052" >&nbsp;&nbsp;Lima</option>
      
        
        <option value="11536619" >&nbsp;&nbsp;Linwood</option>
      
        
        <option value="2138244" >&nbsp;&nbsp;Lyons</option>
      
        
        <option value="2134365" >&nbsp;&nbsp;Macedon</option>
      
        
        <option value="2139353" >&nbsp;&nbsp;Medina</option>
      
        
        <option value="2144826" >&nbsp;&nbsp;Middlesex</option>
      
        
        <option value="14247064" >&nbsp;&nbsp;Mount Morris</option>
      
        
        <option value="2125566" >&nbsp;&nbsp;Mumford</option>
      
        
        <option value="2134495" >&nbsp;&nbsp;Naples</option>
      
        
        <option value="9863757" >&nbsp;&nbsp;Palmyra</option>
      
        
        <option value="2139627" >&nbsp;&nbsp;Penn Yan</option>
      
        
        <option value="2144625" >&nbsp;&nbsp;Perry</option>
      
        
        <option value="2255802" >&nbsp;&nbsp;Phelps</option>
      
        
        <option value="2125461" >&nbsp;&nbsp;Pultneyville</option>
      
        
        <option value="2286124" >&nbsp;&nbsp;Romulus</option>
      
        
        <option value="2138091" >&nbsp;&nbsp;Seneca Falls</option>
      
        
        <option value="2138131" >&nbsp;&nbsp;Shortsville</option>
      
        
        <option value="13384852" >&nbsp;&nbsp;Skaneateles</option>
      
        
        <option value="2125540" >&nbsp;&nbsp;Sodus</option>
      
        
        <option value="2142982" >&nbsp;&nbsp;Sterling</option>
      
        
        <option value="2125287" >&nbsp;&nbsp;Victor</option>
      
        
        <option value="13673026" >&nbsp;&nbsp;Wyoming</option>
      
        
        <option value="2146479" >&nbsp;&nbsp;Pavillon</option>
      
        
        <option value="2247719" >&nbsp;&nbsp;Livonia</option>
      
    
  </select>
      <input type="text" size="18" name="keywords" title="Enter keyword" class="text" value="" />
      <input type="hidden" name="ongoing" value="Timely" />
      <input type="submit" value="go" />
    </form>
      <a href="https://posting.rochestercitynewspaper.com/rochester/Events/AddEvent">Submit an event</a>
  </div>


  

  <div id="calendarBody-music" class="eventSearchBody" style="display:none">
    <form name="musicEventSearchForm" method="get" action="https://www.rochestercitynewspaper.com/rochester/EventSearch">
      <input type="hidden" name="eventSection" value="2124770" />

      <select name="narrowByDate">
    <option value="">-All Dates-</option>
    
    
      
      
        
        
          <option value="2022-08-08" selected="selected">Monday, August  8</option>
        
      
        
        
          <option value="2022-08-09">Tuesday, August  9</option>
        
      
        
        
          <option value="2022-08-10">Wednesday, August 10</option>
        
      
        
        
          <option value="2022-08-11">Thursday, August 11</option>
        
      
        
        
          <option value="2022-08-12">Friday, August 12</option>
        
      
        
        
          <option value="2022-08-13">Saturday, August 13</option>
        
      
        
        
          <option value="2022-08-14">Sunday, August 14</option>
        
      
        
        
          <option value="2022-08-15">Monday, August 15</option>
        
      
        
        
          <option value="2022-08-16">Tuesday, August 16</option>
        
      
        
        
          <option value="2022-08-17">Wednesday, August 17</option>
        
      
        
        
          <option value="2022-08-18">Thursday, August 18</option>
        
      
        
        
          <option value="2022-08-19">Friday, August 19</option>
        
      
        
        
          <option value="2022-08-20">Saturday, August 20</option>
        
      
        
        
          <option value="2022-08-21">Sunday, August 21</option>
        
      
        
        
          <option value="2022-08-22">Monday, August 22</option>
        
      
        
        
          <option value="2022-08-23">Tuesday, August 23</option>
        
      
        
        
          <option value="2022-08-24">Wednesday, August 24</option>
        
      
        
        
          <option value="2022-08-25">Thursday, August 25</option>
        
      
        
        
          <option value="2022-08-26">Friday, August 26</option>
        
      
        
        
          <option value="2022-08-27">Saturday, August 27</option>
        
      
        
        
          <option value="2022-08-28">Sunday, August 28</option>
        
      
        
        
          <option value="2022-08-29">Monday, August 29</option>
        
      
        
        
          <option value="2022-08-30">Tuesday, August 30</option>
        
      
        
        
          <option value="2022-08-31">Wednesday, August 31</option>
        
      
        
        
          <option value="2022-09-01">Thursday, September  1</option>
        
      
        
        
          <option value="2022-09-02">Friday, September  2</option>
        
      
        
        
          <option value="2022-09-03">Saturday, September  3</option>
        
      
        
        
          <option value="2022-09-04">Sunday, September  4</option>
        
      
        
        
          <option value="2022-09-05">Monday, September  5</option>
        
      
        
        
          <option value="2022-09-06">Tuesday, September  6</option>
        
      
        
        
          <option value="2022-09-07">Wednesday, September  7</option>
        
      
    
  </select>

      <select name="eventCategory">
        <option value="">-All Categories-</option>
        
          <option value="2124786" >Acoustic/Folk</option>
        
          <option value="5494922" >Americana</option>
        
          <option value="2125068" >Blues</option>
        
          <option value="2125069" >Classical</option>
        
          <option value="8025273" >Contemporary Classical</option>
        
          <option value="2125393" >Country</option>
        
          <option value="2125070" >DJ/Electronic</option>
        
          <option value="11123705" >Funk/Groove</option>
        
          <option value="11119979" >Gospel</option>
        
          <option value="8486889" >Halloween Theme</option>
        
          <option value="2125201" >Hip-Hop/Rap</option>
        
          <option value="9546606" >Indie</option>
        
          <option value="8953008" >Industrial</option>
        
          <option value="10887782" >Jam Band</option>
        
          <option value="2125057" >Jazz</option>
        
          <option value="2125071" >Karaoke</option>
        
          <option value="11552258" >Live Stream</option>
        
          <option value="2392846" >Metal</option>
        
          <option value="9155532" >New Year&#39;s</option>
        
          <option value="7534692" >Noise/Experimental</option>
        
          <option value="2125072" >Open Mic</option>
        
          <option value="2124790" >Pop/Rock</option>
        
          <option value="12954518" >Pops/Standards</option>
        
          <option value="5557259" >Punk/Hardcore</option>
        
          <option value="2125073" >R&amp;B/ Soul</option>
        
          <option value="9977503" >Record Store Day</option>
        
          <option value="2125074" >Reggae</option>
        
          <option value="7610550" >Rockabilly</option>
        
          <option value="10897401" >Seasonal</option>
        
          <option value="9607901" >Ska</option>
        
          <option value="2392844" >Traditional</option>
        
          <option value="9435273" >Tropical</option>
        
          <option value="9948971" >Various</option>
        
          <option value="2392845" >Vocals</option>
        
          <option value="9033633" >World</option>
        
          <option value="5494919" >Zydeco</option>
        
      </select>

      <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="2134278" >CITY OF ROCHESTER</option>
        
        <option value="2229831" >&nbsp;&nbsp;College Town</option>
      
        
        <option value="2124863" >&nbsp;&nbsp;Downtown</option>
      
        
        <option value="2134282" >&nbsp;&nbsp;19th Ward</option>
      
        
        <option value="2134285" >&nbsp;&nbsp;Alphabet Streets</option>
      
        
        <option value="2134286" >&nbsp;&nbsp;Beechwood</option>
      
        
        <option value="2134287" >&nbsp;&nbsp;Brown Square</option>
      
        
        <option value="2134288" >&nbsp;&nbsp;Browncroft</option>
      
        
        <option value="2134289" >&nbsp;&nbsp;Bull&#39;s Head</option>
      
        
        <option value="2134291" >&nbsp;&nbsp;COTS</option>
      
        
        <option value="2134292" >&nbsp;&nbsp;Charlotte</option>
      
        
        <option value="2134293" >&nbsp;&nbsp;Cobbs Hill</option>
      
        
        <option value="2134294" >&nbsp;&nbsp;Corn Hill</option>
      
        
        <option value="2134295" >&nbsp;&nbsp;East Avenue</option>
      
        
        <option value="2134296" >&nbsp;&nbsp;East End</option>
      
        
        <option value="2134297" >&nbsp;&nbsp;Edgerton</option>
      
        
        <option value="2134298" >&nbsp;&nbsp;Genesee-Jefferson</option>
      
        
        <option value="2134299" >&nbsp;&nbsp;Group 14621</option>
      
        
        <option value="2134300" >&nbsp;&nbsp;Grove Place</option>
      
        
        <option value="2134301" >&nbsp;&nbsp;High Falls</option>
      
        
        <option value="2134302" >&nbsp;&nbsp;Highland Park</option>
      
        
        <option value="2134303" >&nbsp;&nbsp;Homestead Heights</option>
      
        
        <option value="2134304" >&nbsp;&nbsp;JOSANA</option>
      
        
        <option value="2134323" >&nbsp;&nbsp;Lyell-Otis</option>
      
        
        <option value="2134324" >&nbsp;&nbsp;Maplewood</option>
      
        
        <option value="2134325" >&nbsp;&nbsp;Marketview Heights</option>
      
        
        <option value="2134327" >&nbsp;&nbsp;Monroe Village</option>
      
        
        <option value="2125238" >&nbsp;&nbsp;Mount Hope</option>
      
        
        <option value="2124698" >&nbsp;&nbsp;Neighborhood of the Arts</option>
      
        
        <option value="2134329" >&nbsp;&nbsp;North Winton Village</option>
      
        
        <option value="2134330" >&nbsp;&nbsp;Northland-Lyceum</option>
      
        
        <option value="2125223" >&nbsp;&nbsp;Park Avenue</option>
      
        
        <option value="2134331" >&nbsp;&nbsp;Pearl-Meigs-Monroe</option>
      
        
        <option value="2134332" >&nbsp;&nbsp;Plymouth-Exchange</option>
      
        
        <option value="12606013" >&nbsp;&nbsp;Seabreeze</option>
      
        
        <option value="2134333" >&nbsp;&nbsp;South Wedge</option>
      
        
        <option value="2134343" >&nbsp;&nbsp;St. Paul Quarter</option>
      
        
        <option value="2134334" >&nbsp;&nbsp;Susan B. Anthony</option>
      
        
        <option value="2134336" >&nbsp;&nbsp;Swillburg</option>
      
        
        <option value="2134337" >&nbsp;&nbsp;U.N.I.T.</option>
      
        
        <option value="2134338" >&nbsp;&nbsp;Upper Falls</option>
      
        
        <option value="2134339" >&nbsp;&nbsp;Upper Monroe Avenue</option>
      
        
        <option value="2134340" >&nbsp;&nbsp;Upper Mount Hope</option>
      
        
        <option value="2134341" >&nbsp;&nbsp;Wadsworth Square</option>
      
        
        <option value="2216396" >&nbsp;&nbsp;Laurelton</option>
      
        
          <option value="2134317" >GREATER ROCHESTER</option>
        
        <option value="2131964" >&nbsp;&nbsp;Brighton</option>
      
        
        <option value="2125582" >&nbsp;&nbsp;Brockport</option>
      
        
        <option value="2136431" >&nbsp;&nbsp;Bushnell&#39;s Basin</option>
      
        
        <option value="2134250" >&nbsp;&nbsp;Chili</option>
      
        
        <option value="2134261" >&nbsp;&nbsp;Churchville</option>
      
        
        <option value="2125260" >&nbsp;&nbsp;East Rochester</option>
      
        
        <option value="2125282" >&nbsp;&nbsp;Fairport</option>
      
        
        <option value="2125274" >&nbsp;&nbsp;Gates</option>
      
        
        <option value="2134080" >&nbsp;&nbsp;Greece</option>
      
        
        <option value="2134255" >&nbsp;&nbsp;Hamlin</option>
      
        
        <option value="2125267" >&nbsp;&nbsp;Henrietta</option>
      
        
        <option value="2125298" >&nbsp;&nbsp;Hilton</option>
      
        
        <option value="2125347" >&nbsp;&nbsp;Honeoye Falls</option>
      
        
        <option value="2125731" >&nbsp;&nbsp;Irondequoit</option>
      
        
        <option value="2134267" >&nbsp;&nbsp;Mendon</option>
      
        
        <option value="2138341" >&nbsp;&nbsp;North Chili</option>
      
        
        <option value="2134257" >&nbsp;&nbsp;Ogden</option>
      
        
        <option value="2125270" >&nbsp;&nbsp;Park Point</option>
      
        
        <option value="2131978" >&nbsp;&nbsp;Penfield</option>
      
        
        <option value="2125579" >&nbsp;&nbsp;Perinton</option>
      
        
        <option value="2125244" >&nbsp;&nbsp;Pittsford</option>
      
        
        <option value="2134266" >&nbsp;&nbsp;Rush</option>
      
        
        <option value="2125783" >&nbsp;&nbsp;Scottsville</option>
      
        
        <option value="2134258" >&nbsp;&nbsp;Spencerport</option>
      
        
        <option value="2134275" >&nbsp;&nbsp;Sweden</option>
      
        
        <option value="2125277" >&nbsp;&nbsp;Webster</option>
      
        
        <option value="2134272" >&nbsp;&nbsp;Wheatland</option>
      
        
          <option value="13672859" >ROCHESTER REGION</option>
        
        <option value="2184747" >&nbsp;&nbsp;Albion</option>
      
        
        <option value="2142743" >&nbsp;&nbsp;Alton</option>
      
        
        <option value="2134491" >&nbsp;&nbsp;Auburn</option>
      
        
        <option value="2201937" >&nbsp;&nbsp;Aurora</option>
      
        
        <option value="2161507" >&nbsp;&nbsp;Avon</option>
      
        
        <option value="2131961" >&nbsp;&nbsp;Batavia</option>
      
        
        <option value="11064499" >&nbsp;&nbsp;Bloomfield</option>
      
        
        <option value="4446507" >&nbsp;&nbsp;Caledonia</option>
      
        
        <option value="2125199" >&nbsp;&nbsp;Canandaigua</option>
      
        
        <option value="2216252" >&nbsp;&nbsp;Clifton Springs</option>
      
        
        <option value="2250745" >&nbsp;&nbsp;Corning</option>
      
        
        <option value="2125263" >&nbsp;&nbsp;Darien</option>
      
        
        <option value="2136578" >&nbsp;&nbsp;Farmington</option>
      
        
        <option value="2139668" >&nbsp;&nbsp;Geneseo</option>
      
        
        <option value="2125585" >&nbsp;&nbsp;Geneva</option>
      
        
        <option value="14393150" >&nbsp;&nbsp;Hemlock</option>
      
        
        <option value="2227154" >&nbsp;&nbsp;Holley</option>
      
        
        <option value="2331864" >&nbsp;&nbsp;Honeoye</option>
      
        
        <option value="2138112" >&nbsp;&nbsp;Interlaken</option>
      
        
        <option value="2125230" >&nbsp;&nbsp;Letchworth</option>
      
        
        <option value="2141052" >&nbsp;&nbsp;Lima</option>
      
        
        <option value="11536619" >&nbsp;&nbsp;Linwood</option>
      
        
        <option value="2138244" >&nbsp;&nbsp;Lyons</option>
      
        
        <option value="2134365" >&nbsp;&nbsp;Macedon</option>
      
        
        <option value="2139353" >&nbsp;&nbsp;Medina</option>
      
        
        <option value="2144826" >&nbsp;&nbsp;Middlesex</option>
      
        
        <option value="14247064" >&nbsp;&nbsp;Mount Morris</option>
      
        
        <option value="2125566" >&nbsp;&nbsp;Mumford</option>
      
        
        <option value="2134495" >&nbsp;&nbsp;Naples</option>
      
        
        <option value="9863757" >&nbsp;&nbsp;Palmyra</option>
      
        
        <option value="2139627" >&nbsp;&nbsp;Penn Yan</option>
      
        
        <option value="2144625" >&nbsp;&nbsp;Perry</option>
      
        
        <option value="2255802" >&nbsp;&nbsp;Phelps</option>
      
        
        <option value="2125461" >&nbsp;&nbsp;Pultneyville</option>
      
        
        <option value="2286124" >&nbsp;&nbsp;Romulus</option>
      
        
        <option value="2138091" >&nbsp;&nbsp;Seneca Falls</option>
      
        
        <option value="2138131" >&nbsp;&nbsp;Shortsville</option>
      
        
        <option value="13384852" >&nbsp;&nbsp;Skaneateles</option>
      
        
        <option value="2125540" >&nbsp;&nbsp;Sodus</option>
      
        
        <option value="2142982" >&nbsp;&nbsp;Sterling</option>
      
        
        <option value="2125287" >&nbsp;&nbsp;Victor</option>
      
        
        <option value="13673026" >&nbsp;&nbsp;Wyoming</option>
      
        
        <option value="2146479" >&nbsp;&nbsp;Pavillon</option>
      
        
        <option value="2247719" >&nbsp;&nbsp;Livonia</option>
      
    
  </select>

      <input type="text" size="18" name="keywords" title="Enter keyword" class="text" value="" />
      <input type="submit" value="go" />
    </form>

    <a href="https://posting.rochestercitynewspaper.com/rochester/Events/AddEvent">Submit an event</a>
  </div>

</div>









<script type="text/javascript"><!--
  Event.observe(document, "dom:loaded", function () {
      dnSetupTabGroup(
          $$("#EventChooser div.tabs>div"),
          $$("#EventChooser div.eventSearchBody"),
          "tabCurrent", "tabBack", 0
      );

      // Deactivate links.
      $$("#EventChooser div.tabs>div a").each(function (a) {
          a.onclick = function () { return false; };
      });
  });
//--></script>



        </div>
        
        <!-- Zone F -->
        <div id="homeSidebarLeft">
          
        </div>
        <!-- Zone G -->
        <div id="homeSidebarRight">
          
        </div>
        <div class="clear"></div>
        <!-- Zone H -->
      <div id="homeSidebarBtm">
        <div id="TwitterWidgetRochester" class="HomeSidebar ContentFullWidth ">
  <h3>Tweets @RocCityNews</h3>
  <a class="twitter-timeline"  href="https://twitter.com/roccitynews"  data-widget-id="345637461659095041" data-chrome="noheader nofooter noborders" width="310" height="300">Tweets by @roccitynews</a>
  <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
</div>
      </div>  
    </div>
    <div class="clear"></div>
    </div><!-- end gridMain -->
    <!-- Footer -->
    <div id="gridFooter">
      
<!-- Custom Macros -->
  <script>
  (function() {
  if(document.getElementById('commitchange-script')) return;
  var npo = 5423;
  var script = document.createElement('script');
  var first = document.getElementsByTagName('script')[0];
  script.setAttribute('data-npo-id', npo);
  script.id = 'commitchange-script';
  script.src = 'https://us.commitchange.com/js/donate-button.v2.js';
  first.parentNode.insertBefore(script, first);
  })();
  </script>
<!-- Custom Macros -->
  <a data-amounts='5.85,10,50,100,585' class='commitchange-donate' data-fixed='' data-hide-dedication=''></a>


    <div id="FooterNavigation" class="GlobalFooter ContentFullWidth ">
      <ul>
  
  
  <li class="">
    <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives" target="_self">
      
        Article Archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.rochestercitynewspaper.com/rochester/IssueArchives" target="_self">
      
        Issue Archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.issuu.com/roccitynews" target="_blank">
      
        PDF Archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.rochestercitynewspaper.com/rochester/AboutUs/Page" target="_self">
      
        Contact Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.rochestercitynewspaper.com/rochester/PrivacyPolicy/Page" target="_self">
      
        Privacy Policy
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://mailchi.mp/rochester-citynews.com/newsletters" target="_blank">
      
        Subscribe to our Email Newsletter
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.rochestercitynewspaper.com/rochester/work-with-us/Content?oid=10888717" target="_self">
      
        Work with Us
      
    </a>
    
    
  </li> 
  

      </ul>
    </div>
  





<div id="footerCopyright">
  <p>
   Website powered by <a href="https://publishwithfoundation.com/gyrobase/site/showcase" target="_blank">Foundation</a>
   &nbsp; &nbsp; | &nbsp; &nbsp; 
   &copy; 2022
   <a href="/rochester/AboutUs/Page">CITY News</a>
  </p>
</div><!-- GOOGLE ANALYTICS & QUANTCAST TAGS MOVED TO CODE FIELD OF SEARCH LOGIN COMPONENT -->

<!-- cXense script begin -->
<div id="cX-root" style="display:none"></div>
<script type="text/javascript">
var cX = cX || {}; cX.callQueue = cX.callQueue || [];
cX.callQueue.push(['setAccountId', '9222291968715708015']);
cX.callQueue.push(['setSiteId', '9222304501162646030']);
cX.callQueue.push(['sendPageViewEvent']);
</script>
<script type="text/javascript">
(function() { try { var scriptEl = document.createElement('script'); scriptEl.type = 'text/javascript'; scriptEl.async = 'async';
scriptEl.src = ('https:' == document.location.protocol) ? 'https://scdn.cxense.com/cx.js' : 'http://cdn.cxense.com/cx.js';
var targetEl = document.getElementsByTagName('script')[0]; targetEl.parentNode.insertBefore(scriptEl, targetEl); } catch (e) {};} ());
</script>
<!-- cXense script end --><div id="AdWallpaper" class="GlobalFooter ContentFullWidth Ad MediumRectangle">
  <!-- /1843875/CITY_WALLPAPER -->
          <div id="div-gpt-ad-city_wallpaper" style="" data-content-type="ad" data-slot="/1843875/CITY_WALLPAPER" data-output="asynchronous" data-width="1" data-height="1">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-city_wallpaper');
                });
              </script>
          </div>
</div>
    </div><!-- end gridFooter -->
  
</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  
</div><!-- end gridCloser -->
    </body>
</html>
  


