

























































    
         
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Content Default" />
  
    <meta name="oid" content="11090556" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=69f13cbd1e35df6d586d76ef156f0613" />
  <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=69f13cbd1e35df6d586d76ef156f0613" />
  <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=69f13cbd1e35df6d586d76ef156f0613" />
  <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=69f13cbd1e35df6d586d76ef156f0613" />

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="City Newspaper RSS: Whole Site" href="https://www.rochestercitynewspaper.com/rochester/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="City Newspaper RSS: News &amp; Opinion Section" href="https://www.rochestercitynewspaper.com/rochester/Rss.xml?oid=2124539" />
    
    
      <link rel="alternate" type="application/rss+xml" title="City Newspaper RSS: News" href="https://www.rochestercitynewspaper.com/rochester/Rss.xml?oid=2124545" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="City Newspaper RSS: Comments on News" href="https://www.rochestercitynewspaper.com/rochester/Rss.xml?id=comments&amp;oid=2124545" />
      
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
      
      <script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=9b40d38f9c39e56bb2fc7c74dbd49420"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=9b40d38f9c39e56bb2fc7c74dbd49420"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  
  

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.rochestercitynewspaper.com\/rochester\/Profile", "https:\/\/posting.rochestercitynewspaper.com\/rochester\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="680739014388-nuf1n6j57rgv8jjra50l5hbad16nactb.apps.googleusercontent.com">
  

    
  

  
  

  <script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function() {
              var gads = document.createElement('script');
              gads.async = true;
              gads.type = 'text/javascript';
              var useSSL = 'https:' == document.location.protocol;
              gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
              var node = document.getElementsByTagName('script')[0];
              node.parentNode.insertBefore(gads, node);
            })();
          </script>
          <script type='text/javascript'>
            googletag.cmd.push(function() {
              Foundation = Foundation || {};
              Foundation.Ad = Foundation.Ad || {};
              Foundation.Ad.slots = Foundation.Ad.slots || {};
                  Foundation.Ad.slots['div-gpt-ad-city_leaderboard'] = googletag.defineSlot('/1843875/CITY_LEADERBOARD', [[728, 90], [970, 90]], 'div-gpt-ad-city_leaderboard').addService(googletag.pubads());
                  Foundation.Ad.slots['div-gpt-ad-city_med_rect_1'] = googletag.defineSlot('/1843875/CITY_MED_RECT_1', [300, 250], 'div-gpt-ad-city_med_rect_1').addService(googletag.pubads());
                  Foundation.Ad.slots['div-gpt-ad-city_med_rect_2'] = googletag.defineSlot('/1843875/CITY_MED_RECT_2', [300, 250], 'div-gpt-ad-city_med_rect_2').addService(googletag.pubads());
                  Foundation.Ad.slots['div-gpt-ad-city_sitewide_dd_ad'] = googletag.defineSlot('/1843875/CITY_Sitewide_DD_Ad', [300, 100], 'div-gpt-ad-city_sitewide_dd_ad').addService(googletag.pubads());
                  Foundation.Ad.slots['div-gpt-ad-city_sitewide_ur_ad'] = googletag.defineSlot('/1843875/CITY_Sitewide_UR_Ad', [300, 100], 'div-gpt-ad-city_sitewide_ur_ad').addService(googletag.pubads());
                  googletag.pubads().setTargeting('template', ["Content"]);
                  googletag.pubads().setTargeting('media', ["screen"]);
                  googletag.pubads().setTargeting('section', ["newsopinion"]);
                  googletag.pubads().setTargeting('category', ["News"]);
                  googletag.pubads().setTargeting('oid', ["11090556"]);
                  googletag.pubads().setTargeting('tags', ["Robin Wilt","Joe Morelle","2020 elections","House of Representatives","25th Congressional District","Democratic primaries","politics"]);
              googletag.pubads().collapseEmptyDivs();
                googletag.enableServices();
              Foundation.Ad.refresh = function (id) {
                if (id && Foundation.Ad.slots[id]) {
                  // Clean up ad container.
                  jQuery('#' + id).css({width: '', height: ''});
                  // Refresh slot.
                  googletag.pubads().refresh([Foundation.Ad.slots[id]]);
                }
                else {
                  // Clean up all ad containers.
                  jQuery('[data-content-type="ad"]').css({width: '', height: ''});
                  // Refresh all (refreshable) slots.  Wish I could use Object.values().
                  var slots = [];
                  for (var id in Foundation.Ad.slots) {
                    if (Foundation.Ad.slots[id].refresh) {
                      slots.push(Foundation.Ad.slots[id]);
                    }
                  }
                  googletag.pubads().refresh(slots);
                }
              };
              // Refresh on foundation:ad:refresh jQuery event.
              Foundation.Ad.refreshlockout = false;
              jQuery(document).on("foundation:ad:refresh", function(event) {
                if (Foundation.Ad.refreshlockout == false) {
                  Foundation.Ad.refreshlockout = true;
                  window.setTimeout(function () {
                    Foundation.Ad.refreshlockout = false;
                  }, 2500);
                  Foundation.Ad.refresh();
                }
              });
              // Mark slots refreshable by default.
              for (var id in Foundation.Ad.slots) {
                if (!('refresh' in Foundation.Ad.slots[id])) {
                  Foundation.Ad.slots[id].refresh = true;
                }
              }
            });
          </script>




<meta name="google-site-verification" content="MK7p28JZYN3KpFUjlcYNrypzqb2B8kvV16nww69JL-A" />
<meta name="google-site-verification" content="35VJLgv516kWfGLi6_2MNNwlGOWgSEneL48dbS9mvaI" />
<meta name="google-site-verification" content="Tw_IYIFDlu_IisIBlHldsSi-cVSL2mP8Izqv4iqzGoE" />
  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="Wilt launches second Congressional bid | News | Rochester City Newspaper" />
  <meta name="description" content="Robin Wilt will challenge incumbent Democrat Joe Morelle." />
  <meta name="keywords" content="Robin Wilt, Joe Morelle, 2020 elections, House of Representatives, 25th Congressional District, Democratic primaries, politics, News, Arts, Entertainment, Events, Music, Calendar, Blog, New York, Rochester, Alternative News, Journalism" />
  <title>Wilt launches second Congressional bid | News | Rochester City Newspaper</title>

  
  
    <meta name="date" content="2019-11-25 11:45:55" />
  

  
  
  
    <meta name="author" content="Randy Gorbman">
  

  
  
  <meta name="news_keywords" content="robin wilt, joe morelle, 2020 elections, house of representatives, 25th congressional district, democratic primaries, politics, news, arts, entertainment" />

  
  
  
    <link rel="image_src" href="https://media1.fdncms.com/rochester/imager/u/slideshow/11090563/wilt_-robin.jpg" />
    <meta name="thumbnail" content="https://media1.fdncms.com/rochester/imager/u/slideshow/11090563/wilt_-robin.jpg" />
  

  
    
      <link rel="canonical" href="https://www.rochestercitynewspaper.com/rochester/wilt-launches-second-congressional-bid/Content?oid=11090556" />
      <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.rochestercitynewspaper.com/rochester/wilt-launches-second-congressional-bid/Content?oid=11090556" />
      
    

    
    
    
      
      
      <link rel="amphtml" href="https://www.rochestercitynewspaper.com/rochester/wilt-launches-second-congressional-bid/Content?oid=11090556&media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="https://www.rochestercitynewspaper.com/rochester/wilt-launches-second-congressional-bid/Content?oid=11090556" />
    
  

  
    <meta property="fb:app_id" content="347460708667425" />
  

  
  <meta property="og:site_name" content="City Newspaper" />
  <meta property="og:title" content="Wilt launches second Congressional bid" />
 
  
    

    
    

    
    

    <meta property="og:image" content="https://media1.fdncms.com/rochester/imager/u/slideshow/11090563/wilt_-robin.jpg" />

    
      <meta property="og:image:width" content="640" />
      <meta property="og:image:height" content="895" />
    
  

  
  
    <meta property="og:description" content="Robin Wilt will challenge incumbent Democrat Joe Morelle." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  

    
    

    
    

    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media1.fdncms.com/rochester/imager/u/slideshow/11090563/wilt_-robin.jpg">

    
    

    

    <meta name="twitter:site" content="@roccitynews">
    <meta name="twitter:title" content="Wilt launches second Congressional bid">
    <meta name="twitter:description" content="Robin Wilt will challenge incumbent Democrat Joe Morelle.">
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">11090556</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20191125124641</Attribute>
        <Attribute name="creationdate">20191125113729</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20191125114555</Attribute>
            <Attribute name="releasedate">20191125</Attribute>
            <Attribute name="releaseepoch">1574700355</Attribute>
            <Attribute name="title">Wilt launches second Congressional bid</Attribute>
            <Attribute name="author">9120774</Attribute>
            <Attribute name="authorname">Randy Gorbman</Attribute>
            <Attribute name="authorsortname">Gorbman, Randy</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"https:\/\/www.rochestercitynewspaper.com\/rochester\/wilt-launches-second-congressional-bid\/Content?oid=11090556"
          },
          "headline": "Wilt launches second Congressional bid",
          
            "description": "Robin Wilt will challenge incumbent Democrat Joe Morelle.",
          
          
            "image": {
              "url": "https:\/\/media1.fdncms.com\/rochester\/imager\/u\/original\/11090563\/wilt_-robin.jpg",
              "width": 572,
              "height": 800,
              "@type": "ImageObject"
            },
          
          "datePublished": "2019-11-25T11:45:55",
          "dateModified": "2019-11-25T12:46:41",
          
            "author": {
              "name": "Randy Gorbman",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "City Newspaper",
            
              
              
              
              "logo": {
                "url": "https:\/\/www.rochestercitynewspaper.com\/imager\/b\/google-amp-logo\/808579\/b0d0\/adminIcon_rochester.jpg",
                "width": 222,
                "height": 222,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


</head>





  <body id="Content" class="ContentDefault Iapetus10Zone News newsopinion">



<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  
</div><!-- end gridLeader -->

<div id="gridClamp">
  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader ContentDefault " style="display:none">
        
        
          Switch to the <a href="https://m.rochestercitynewspaper.com/rochester/wilt-launches-second-congressional-bid/Content?oid=11090556" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      
      function setRedirectHash() {
        if (location.hash) {
          jQuery("#MobileDetect a[media='handheld']").each(function() {
            var link = jQuery(this);
            link.attr('href', link.attr('href').split('#')[0] + location.hash);
          });
        }
      }
      setRedirectHash();

      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  

<!-- NEW Google stats tracking code  April 2014-->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-823140-1', 'rochestercitynewspaper.com');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script>



<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-63s4LXm0U50e-"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-63s4LXm0U50e-.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->




<div id="SearchLogin" class="GlobalHeader ContentDefault ">

  
  

  
      <div>
    
    

    
      <a href="https://twitter.com/#!/roccitynews" title="Twitter" target="_blank"><img alt="Twitter" src="https://media2.fdncms.com/rochester/imager/twitter/u/original/2137392/twitter_new.gif" width="29"></a>
    

    
  
    

    
      <a href="https://www.facebook.com/CityNewspaper" title="Facebook" target="_blank"><img alt="Facebook" src="https://media2.fdncms.com/rochester/imager/facebook/u/original/2137427/facebook_new.gif" width="29"></a>
    

    
  
    

    
      <a href="https://www.instagram.com/roccitynews/" title="Instagram" target="_self"><img alt="Instagram" src="https://media1.fdncms.com/rochester/imager/u/original/10871592/instagram-transparent.jpg" width="29"></a>
    

    
  
    

    
      <a href="/rochester/Syndication" title="RSS" target="_self"><img alt="RSS" src="https://media2.fdncms.com/rochester/imager/rss/u/original/2124579/rss.gif" width="29"></a>
    

    
  
    

    
      <a href="http://www.issuu.com/roccitynews" title="Digital Issues" target="_blank"><img alt="Digital Issues" src="https://media1.fdncms.com/rochester/imager/digital-issues/u/original/2124580/issuu.jpg" width="29"></a>
    

    
  
    

    
      <a href="https://mailchi.mp/rochester-citynews.com/newsletters" title="Subscribe to Newsletter" target="_blank"><img alt="Subscribe to Newsletter" src="https://media1.fdncms.com/rochester/imager/u/original/10871942/enews-icon.png" width="29"></a>
    

    
  
      </div>
    



  
  
  
  
    
    <ul data-view="loggedin" style="display:none">
      <li><strong data-label="username">Username</strong> / </li>
      <li><a href="https://posting.rochestercitynewspaper.com/rochester/MyProfile">View Profile</a> / </li>
      <li><a href="https://posting.rochestercitynewspaper.com/rochester/Profile/MySettings">Edit Profile</a> / </li>
      <li><a href="https://www.rochestercitynewspaper.com/rochester/Logout">Log Out</a></li>
    </ul>

    <ul data-view="loggedout" style="display:none">
      <li><a href="#LogIn">Log in</a> / </li>
      <li><a href="#CreateAccount">Create Account</a></li>
    </ul>
  
  

  

  

  <div id="SearchLoginSiteSearchBox">
    <form class="search-form" action="https://www.rochestercitynewspaper.com/rochester/Search">
      <input type="hidden" name="cx" value="017793458706336421686:dgaybk9sose">
      <input type="hidden" name="cof" value="FORID:9">
      
        <input class="search-input" autocomplete="off" type="text" value="" name="q" size="25" placeholder="">
      
      <div class="searchIcon">
        Search
        <svg version="1.1" id="SearchLoginSiteSearchBoxLayer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="14px" height="14px" viewBox="0 0 14 14" style="enable-background:new 0 0 14 14;" xml:space="preserve"><path d="M10.171,8.766c0.617-0.888,0.979-1.964,0.979-3.126c0-3.037-2.463-5.5-5.5-5.5s-5.5,2.463-5.5,5.5s2.463,5.5,5.5,5.5 c1.152,0,2.223-0.355,3.104-0.962l3.684,3.683l1.414-1.414L10.171,8.766z M5.649,9.14c-1.933,0-3.5-1.567-3.5-3.5 c0-1.933,1.567-3.5,3.5-3.5c1.933,0,3.5,1.567,3.5,3.5C9.149,7.572,7.582,9.14,5.649,9.14z"></path></svg>
      </div>

      
      
        <input type="submit" name="sa" value="Search">
      

      <ul class="search-dropdown" style="display:none;">
        
        
          <li class="search-option"><a class="search-all" href="https://www.rochestercitynewspaper.com/rochester/Search"><span class="search-icon"></span> All</a></li>
    <li class="search-option"><a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives"><span class="search-icon"></span> in Articles &amp; Posts</a></li>
    <li class="search-option"><a href="https://www.rochestercitynewspaper.com/rochester/EventSearch"><span class="search-icon"></span> in Events</a></li>
    <li class="search-option"><a href="https://www.rochestercitynewspaper.com/rochester/LocationSearch"><span class="search-icon"></span> in Locations</a></li>
    <li class="search-option"><a href="https://www.rochestercitynewspaper.com/rochester/SlideshowArchives"><span class="search-icon"></span> in Slideshows</a></li>
        
      </ul>
    </form>

    
      <script>
      "use strict";
      (function(){
        var searchPanel = new Foundation.View.Desktop.RevealPanel({
          hoverSelector: '#SearchLoginSiteSearchBox div.searchIcon',
          clickSelector: '#SearchLoginSiteSearchBox input.search-input',
          panelSelector: '#SearchLoginSiteSearchBox ul.search-dropdown',
          alignSelector: '',
          alignFunction: function(){}
        });

        var searchFormSelector = '#SearchLoginSiteSearchBox form.search-form'
        var searchOptionLinkSelector = '#SearchLoginSiteSearchBox li.search-option a'
        var searchInputSelector = '#SearchLoginSiteSearchBox input.search-input'

        var canProceed = function(obj, searchAllOption){
          var emptyKeyword = jQuery(searchInputSelector).val().trim().length === 0
          // Don't proceed without a keyword on the search-all option
          if(emptyKeyword && searchAllOption){
            return true // allow submission without keyword
          }
          return true
        }

        var enterKeywordMessage = function (){
          jQuery(searchInputSelector).attr('placeholder',"Enter a keyword.")
          window.setTimeout(function(){
            jQuery(searchInputSelector).attr('placeholder',"")
          },1000)
        }

        // 
        jQuery(searchFormSelector).submit(function(e){
          if(!canProceed(e.target, true)){
            e.preventDefault()
            enterKeywordMessage()
          }
        })

        // 
        jQuery(searchOptionLinkSelector).on('click', function(e){
          e.preventDefault()
          if(canProceed(e.target, jQuery(e.target).hasClass('search-all'))){
            if(jQuery(e.target).hasClass('search-all')){
              jQuery(searchFormSelector).submit()
            } else {
              var newLocation = jQuery(e.target).attr('href') || ""
              var catVal = jQuery(e.target).attr('data-category')
              var catParam = catVal != undefined ? "&category="+catVal : ""
              window.location = newLocation 
                              + "?keywords=" + jQuery(searchInputSelector).val() 
                              + "&submit=Search" 
                              + catParam
            }
          }else{
            enterKeywordMessage()
          }
        })
      })()
      </script>
    
  </div>

</div>



  <script>
    new Foundation.LoginRequiredComponent("SearchLogin");
  </script>

  



<div id="LogoandLeaderboard" class="GlobalHeader ContentDefault ">
  <div id="header-logo" class="admin">
    
      <div id="logo"><a href="https://www.rochestercitynewspaper.com/" title="City Newspaper"><img src="/images/logos/CityRevisedHeader.png" alt="City Newspaper" title="City Newspaper" width="542" height="88" /></a></div>
    
  </div>
</div>





<script type="text/javascript">
    Event.observe(document, "dom:loaded", function () {
      var yOffset = jQuery('#NavigationHorizontal').offset().top
      jQuery(window).scroll(function(){
        var pos = jQuery(document).scrollTop() - yOffset
        if (pos >= 0) {
          jQuery("#NavigationHorizontal").addClass('sticky')
        } else {
          jQuery("#NavigationHorizontal").removeClass('sticky')
        }
      })
    })
    </script>














  <div id="NavigationHorizontal" class="GlobalHeader ContentDefault  ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first" id="NavItem_Home">
          <a href="https://www.rochestercitynewspaper.com/"  class="subnav_link" id="SNAVL_Home">Home</a>
        </li>
        
      
        

        

        

        

        <li class="navCurrent" id="NavItem_News">
          <a href="https://www.rochestercitynewspaper.com/rochester/news-and-opinion/Section?oid=2124539"  class="subnav_link" id="SNAVL_News">News</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_ArtsEntertainment">
          <a href="https://www.rochestercitynewspaper.com/rochester/arts-and-entertainment/Section?oid=2124540"  class="subnav_link" id="SNAVL_ArtsEntertainment">Arts &amp; Entertainment</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Music">
          <a href="https://www.rochestercitynewspaper.com/rochester/music/Section?oid=2124542"  class="subnav_link" id="SNAVL_Music">Music</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Restaurants">
          <a href="https://www.rochestercitynewspaper.com/rochester/restaurants/Section?oid=2124544"  class="subnav_link" id="SNAVL_Restaurants">Restaurants</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_events">
          <a href="https://www.rochestercitynewspaper.com/rochester/EventSearch"  class="subnav_link" id="SNAVL_events">Events</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Guides">
          <a href="https://www.rochestercitynewspaper.com/rochester/special-sections/Section?oid=2124823"  class="subnav_link" id="SNAVL_Guides">Guides</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Classifieds">
          <a href="http://www.verican.us/cod6/rochestercitynewspaper/" target="_blank" class="subnav_link" id="SNAVL_Classifieds">Classifieds</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Advertise">
          <a href="https://www.rochestercitynewspaper.com/rochester/marketing-portfolio/Content?oid=10892070"  class="subnav_link" id="SNAVL_Advertise">Advertise</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_WXXI">
          <a href="https://www.wxxi.org/"  class="subnav_link" id="SNAVL_WXXI">WXXI</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse </h3>
            <ul class="subnav_content" id="SNAV_" style="display:none;">
          

          

          <li class="">
            <a href="http://city.zagpad.com/ForSale.aspx" target="_blank" title="">Home for Sale</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.verican.us/cod6/adlisting.do?catalog=rochestercitynewspaper&list=true&category=150000&heading=101" target="_blank" title="">Apartment Rentals</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://city.zagpad.com/Monroe/ForRent/RentalCommunities.aspx"  title="">Rental Communities</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse News</h3>
            <ul class="subnav_content" id="SNAV_News" style="display:none;">
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/editors-notebook/Category?oid=10897198"  title="">Editor&#39;s Notebook</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/news/Category?oid=2124545"  title="">News</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/urban-journal/Category?oid=2124547"  title="">Urban Journal</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/urban-action/Category?oid=2124546"  title="">Urban Action</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/feedback/Category?oid=2124550"  title="">Feedback</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?section=2124539"  title="">News &amp; Opinion Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Music</h3>
            <ul class="subnav_content" id="SNAV_Music" style="display:none;">
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/blogs/MusicBlog/"  title="">Music Blog</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/music-features/Category?oid=2124556"  title="">Music Features</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/classical/Category?oid=2124554"  title="">Classical</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/choice-concerts/Category?oid=2124583"  title="">Choice Concerts</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/music-reviews/Category?oid=2124557"  title="">Music Reviews</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/EventSearch?sortType=title&eventSection=2124770"  title="">Local Music Guide</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?section=2124542"  title="">Music Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Arts &amp; Entertainment</h3>
            <ul class="subnav_content" id="SNAV_ArtsEntertainment" style="display:none;">
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/art/Category?oid=2124551"  title="">Art</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/culture/Category?oid=2124804"  title="">Culture</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/dance/Category?oid=2124799"  title="">Dance</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?category=6131363"  title="">Literature</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/movies/Section?oid=2124830"  title="">Movies</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/theater/Category?oid=2124552"  title="">Theater</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/art-work-episode-5-nick-brandreth/Content?oid=5870406"  title="">art/WORK</a>
          </li>
          
        
          

          

          <li class="searchItem">
            <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?section=2124540"  title="">Arts &amp; Entertainment Archives</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Events</h3>
            <ul class="subnav_content" id="SNAV_events" style="display:none;">
          

          

          <li class="searchItem">
            <a href="https://www.rochestercitynewspaper.com/rochester/EventSearch?narrowByDate=Today&sortType=title"  title="">Event Listings</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/choice-events/Category?oid=2124582"  title="">Choice Events</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/choice-concerts/Category?oid=2124583"  title="">Choice Concerts</a>
          </li>
          
        
          

          

          <li class="submitItem">
            <a href="https://www.rochestercitynewspaper.com/rochester/Events/AddEvent"  title="">Submit an Event</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Restaurants</h3>
            <ul class="subnav_content" id="SNAV_Restaurants" style="display:none;">
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/dining-reviews/Category?oid=2124559"  title="">Dining Reviews</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/restaurant-news/Category?oid=2124813"  title="">Restaurant News</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Classifieds</h3>
            <ul class="subnav_content" id="SNAV_Classifieds" style="display:none;">
          

          

          <li class="">
            <a href="http://www.verican.us/cod6/adlisting.do?catalog=rochestercitynewspaper&list=true&category=60000" target="_blank" title="">Employment</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.verican.us/cod6/adlisting.do?catalog=rochestercitynewspaper&list=true&category=30000" target="_blank" title="">Automotive</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.verican.us/cod6/adlisting.do?catalog=rochestercitynewspaper&list=true&category=80000" target="_blank" title="">Garage &amp; Yard Sales</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://www.verican.us/cod6/adlisting.do?catalog=rochestercitynewspaper&list=true" target="_blank" title="">More...</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Guides</h3>
            <ul class="subnav_content" id="SNAV_Guides" style="display:none;">
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/dont-bug-out/Content?oid=10374188"  title="">Summer Guide 2019</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/jazz-festival-guide-2018/Content?oid=6798139"  title="">Jazz Festival 2018</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/jazz-festival-guide-2019/Content?oid=10434165"  title="">Jazz Festival 2019</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/seventh-annual-keybank-rochester-fringe-festival/Content?oid=7851902"  title="">Rochester Fringe Festival 2018</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/life-beyond-the-campus/Content?oid=10740888"  title="">CITY U 2019</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/fall-guide-2018-relishing-the-season/Content?oid=8036655"  title="">Fall Guide 2018</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/fringe-festival-guide-2019/Content?oid=10770875"  title="">Rochester Fringe Festival 2019</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/bah-humbug/Content?oid=11068249"  title="">Holiday Guide 2019</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/holiday-guide-2018/Content?oid=8768563"  title="">Holiday Guide 2018</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/fall-guide-2019/Content?oid=10829680"  title="">Fall Guide19</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/winter-guide/Content?oid=9410915"  title="">Winter Guide 2019</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/building-a-better-rochester/Content?oid=9837139"  title="">Annual Manual 2019</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.rochestercitynewspaper.com/rochester/ate-days-a-week/Content?oid=10313927"  title="">Dish 2019</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse WXXI</h3>
            <ul class="subnav_content" id="SNAV_WXXI" style="display:none;">
          

          

          <li class="">
            <a href="https://www.wxxinews.org/"  title="">Newsroom</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.wxxi.org/tv"  title="">Television</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.wxxi.org/radio"  title="">Radio</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://thelittle.org/"  title="">The Little</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.wxxi.org/education"  title="">Education</a>
          </li>
          
            </ul>
          
        

        

        
        
        
      
    
  </div>


  

  
  
  
    
    

      

      <script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>
    
  
  <!-- true == "true"
         && true == "devel" -->


<!-- End #NavigationHorizontal --><div id="Ad970x90" class="GlobalHeader ContentDefault Ad">
  <!-- /1843875/CITY_LEADERBOARD -->
          <div id="div-gpt-ad-city_leaderboard" style="" data-content-type="ad" data-slot="/1843875/CITY_LEADERBOARD" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-city_leaderboard');
                });
              </script>
          </div>
</div>
  </div><!-- end gridHeader -->

  <div id="gridMain">

    <div id="gridFrame">

      <div id="gridSpanningFeature">
        



  
    <div id="StoryBreadcrumb" class="SpanningFeature ContentDefault  news___opinion news">
      <p class="issueInfo ">
        <span class="date">
          
            <a href="https://www.rochestercitynewspaper.com/rochester/IssueArchives?issue=11063555">November 25, 2019</a>
          
        </span>

  			
          <a href="https://www.rochestercitynewspaper.com/rochester/news-and-opinion/Section?oid=2124539">News & Opinion</a>
        
        
          &raquo; <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?category=2124545">News</a>
        
      </p>
    </div> <!-- end StoryBreadcrumb -->
  





  
  















  
  
  

  
  
  

  
 
  




  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="SpanningFeature ContentDefault ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:16%; height: 20px; float:left;">
        <fb:like href="https://www.rochestercitynewspaper.com/rochester/wilt-launches-second-congressional-bid/Content?oid=11090556" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:16%; height: 20px; float:left;"><a href="https://twitter.com/share?url=https%3A//www.rochestercitynewspaper.com/rochester/wilt-launches-second-congressional-bid/Content%3Foid%3D11090556&text=Wilt%20launches%20second%20Congressional%20bid" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:16%; height: 20px; float:left;">


  

  

  

  <a href="https://pinterest.com/pin/create/button/?description=Wilt%20launches%20second%20Congressional%20bid&amp;media=https%3A%2F%2Fmedia1.fdncms.com%2Frochester%2Fimager%2Fu%2Fslideshow%2F11090563%2Fwilt_-robin.jpg&amp;url=https%3A%2F%2Fwww.rochestercitynewspaper.com%2Frochester%2Fwilt-launches-second-congressional-bid%2FContent%3Foid%3D11090556" class="pin-it-button" count-layout="none">Pin It</a>
  <script>
  Foundation.documentReady.then(function () {
    new Foundation.Script("https://assets.pinterest.com/js/pinit.js", true);
  })
  </script>

</div> <div class="l0" style="width:16%; height: 20px; float:left;">

<a class="emailAction" title="." href="https://posting.rochestercitynewspaper.com/rochester/Tools/EmailFriend?oid=11090556" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">.</a>

</div> <div class="l0" style="width:16%; height: 20px; float:left;">


  <a class="toggleActivator saveAction requiresLogin" title="My Favorites" href="https://posting.rochestercitynewspaper.com/rochester/Profile/MyFavorites?add=11090556">
    Favorites
  </a>
  <div class="togglePanel" data-toolsoid="11090556" data-toolsajaxmacro="addObject" style="display:none">
    <div class="loading">Saving&hellip;</div>
    <div class="ajaxUpdater" style="display:none"></div>
  </div>


</div> <div class="l0 last" style="width:16%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=xa-503d61bf5addb3a2" addthis:url="https://www.rochestercitynewspaper.com/rochester/wilt-launches-second-congressional-bid/Content?oid=11090556" addthis:title="Wilt launches second Congressional bid" addthis:description="Robin Wilt will challenge incumbent Democrat Joe Morelle." class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-503d61bf5addb3a2", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  




  

  

  
    <div id="StoryHeader" class="SpanningFeature ContentDefault   home_follows">
      <div class="storyHead">
        
        <h1 class="headline headline-11090556">Wilt launches second Congressional bid&nbsp;</h1>        
        
        
          

          <cite class="byline">
            <span class="byAttribute">By</span> <a href="https://www.rochestercitynewspaper.com/author/randy-gorbman" rel="author">Randy Gorbman</a>
               
          </cite>

          

        
      </div>
    </div> <!-- end StoryHeader -->
  











  
  
  
  
  
    
  




  
  





<div id="StoryLayout" class="SpanningFeature ContentDefault  home_follows">

  

    

    


































    
    

    
      
    
    
    
    
      
      

      
              
    

      
     
       
      
      
      
      
    
      <div id="storyBody" class="page1 home_follows">
        
      
        

        
        
          <div class="contentImageRight" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/rochester/imager/u/original/11090563/wilt_-robin.jpg" class="zoomable" rel="contentImg_gal-11090556" title="Robin Wilt. - FILE PHOTO">                  <img src="https://media1.fdncms.com/rochester/imager/u/blog/11090563/wilt_-robin.jpg?cb=1574704030" width="250" height="350" alt="Robin Wilt. - FILE PHOTO" srcset="" />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              FILE PHOTO                                          </li>                                                                                                                            <li class="imageCaption">                      Robin Wilt.                    </li>                                                                                                </ul>                                                       </div>  Robin Wilt has kicked off her campaign to run again for the 25th Congressional District. That’s the seat now held by Democrat Joe Morelle, who was elected last year to the spot that the late Louise Slaughter held for many years.<br>
 <br>
 Wilt ran unsuccessfully for the same congressional seat in a Democratic primary in June of 2018. She also ran for New York State Assembly last year, but later pulled out of that contest.<br>
 <br>
 Morelle has indicated he plans to run for re-election next year.<br>
 <br>
 “We deserve representation that reflects the priorities of the people of our District, not merely corporations," Wilt said in a statement. "That is why I am running for Congress in 2020.” <br>
 <br>
 Her campaign website says that she is running "to ensure that access to the American Dream is not foreclosed to future generations."<br>
 <br>
 When contacted about a possible opponent last summer, Morelle’s office provided a statement that said he has been, “fighting tirelessly to lower prescription drug prices and protect individuals with pre-existing conditions, safeguard our planet from the devastating effects of climate change, ensure every woman has the right to make her own healthcare decisions, and enact common-sense gun reform like universal background checks.”<br>
<br>
<i>Randy Gorbman is WXXI News director.</i>
        

        
        

        
        
      </div>
    

  
  
</div> <!-- end StoryLayout -->





  
  
  

  <!-- UIkit CSS -->
  <link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.css?cb=18cf9f29886f711e19fcaa8e507c45ff" />

  <!-- UIkit JS -->
  <script src="/fdn-system/assets/pub/scripts/uikit.min.js?cb=18cf9f29886f711e19fcaa8e507c45ff"></script>
  <script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.min.js?cb=18cf9f29886f711e19fcaa8e507c45ff"></script>


  

  <style>
    @media (min-width: 640px){
      div[id] .uk-child-width-1-3\@exs > * {
         width: calc(100% * 1 / 3.001);
      } 
    }
    #gridMainColumn .uk-width-1-2\@es {
      width: 50%;
    }

    #gridMainColumn .uk-child-width-auto\@exs > * {
      width: auto;
    }
    
    .uk-root {
      font-size: 14px;
    }
  </style>



















  

  

  
  

  
    
  

  




















  



    
    
    
    





































 
  <div id="StoryTags" class="SpanningFeature ContentDefault ">
    <p class="tags">Tags: <a href="/rochester/ArticleArchives?category=2124545" rel="tag">News</a>, <a href="/rochester/ArticleArchives?tag=Robin%20Wilt" rel="tag">Robin Wilt</a>, <a href="/rochester/ArticleArchives?tag=Joe%20Morelle" rel="tag">Joe Morelle</a>, <a href="/rochester/ArticleArchives?tag=2020%20elections" rel="tag">2020 elections</a>, <a href="/rochester/ArticleArchives?tag=House%20of%20Representatives" rel="tag">House of Representatives</a>, <a href="/rochester/ArticleArchives?tag=25th%20Congressional%20District" rel="tag">25th Congressional District</a>, <a href="/rochester/ArticleArchives?tag=Democratic%20primaries" rel="tag">Democratic primaries</a>, <a href="/rochester/ArticleArchives?tag=politics" rel="tag">politics</a></p>          
  </div> <!-- end StoryTags -->






  <div id="ArchiveLink" class="SpanningFeature ContentDefault ">
    <p class="moreArticles">
      
        <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?category=2124545">More News &raquo;</a>
      
      
    </p>
  </div> <!-- end ArchiveLink -->




  
  
















  
  
    
  
  
  <div id="TallBar" class="SpanningFeature ContentDefault ">
    <ul>
      <li class="l0 first" style="width:50%">
        <fb:like href="https://www.rochestercitynewspaper.com/rochester/wilt-launches-second-congressional-bid/Content?oid=11090556" send="true" width="275" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="standard"></fb:like></li> <li class="l0" style="width:16%;"><a href="https://twitter.com/share?url=https%3A//www.rochestercitynewspaper.com/rochester/wilt-launches-second-congressional-bid/Content%3Foid%3D11090556&text=Wilt%20launches%20second%20Congressional%20bid" class="twitter-share-button" data-count="vertical">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></li> <li class="l0 last" style="width:16%;">




  <div class="addthis_toolbox addthis_default_style"><a addthis:url="https://www.rochestercitynewspaper.com/rochester/wilt-launches-second-congressional-bid/Content?oid=11090556" addthis:title="Wilt launches second Congressional bid" addthis:description="Robin Wilt will challenge incumbent Democrat Joe Morelle." class="addthis_counter"></a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-503d61bf5addb3a2", true);
  </script>


      </li>
    </ul>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  










      </div><!-- gridSpanningFeature -->
      
      <div id="gridSpanningFeature2">
        
















  
      <div id="RecentByTag" class="SpanningFeature ContentDefault ">
        <h3 class="latestnews">
          <span class="headingText">
          
            Speaking of...
          
          </span>
        </h3>
        
        <ul class="moduleList">

        
        
        
    
    

    
    

    

    
      <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/immigration-finds-some-common-ground-in-local-survey/Content?oid=11090550">
        <img src="https://media2.fdncms.com/rochester/imager/u/review/11090554/forum_dandc.jpg"
             alt="Immigration finds some common ground in local survey"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/immigration-finds-some-common-ground-in-local-survey/Content?oid=11090550">Immigration finds some common ground in local survey</a>
    </h4>
    <div class="date">Nov 25, 2019 </div>
  </li>
    

    
  
    

    
    

    

    
      <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/morelle-impeach-president-trump/Content?oid=10859714">
        <img src="https://media2.fdncms.com/rochester/imager/u/review/10859720/morelle-2-rw.jpg"
             alt="Morelle: begin Trump impeachment proceedings"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/morelle-impeach-president-trump/Content?oid=10859714">Morelle: begin Trump impeachment proceedings</a>
    </h4>
    <div class="date">Sep 24, 2019 </div>
  </li>
    

    
  
    

    
    

    

    
      <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/its-primary-day-polls-are-open/Content?oid=10465734">
        <img src="https://media2.fdncms.com/rochester/imager/u/review/10465910/teaser.jpg"
             alt="It&#39;s primary day, and polls are open"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/its-primary-day-polls-are-open/Content?oid=10465734">It's primary day, and polls are open</a>
    </h4>
    <div class="date">Jun 25, 2019 </div>
  </li>
    

    
  
        

        

        
          <li class="l0 storyItem more">
            <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?tag=Robin%20Wilt%7C%7CJoe%20Morelle%7C%7C2020%20elections%7C%7CHouse%20of%20Representatives%7C%7C25th%20Congressional%20District%7C%7CDemocratic%20primaries%7C%7Cpolitics" class="more">More &raquo;</a>
          </li>
        
        </ul>
      </div>
    
  







  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  
  


  

  
    
      <style>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</style>
      <div id="Comments" class="SpanningFeature ContentDefault CommentsComponent  closed">
        
        
        <div class="commentsHeader hreview-aggregate clearfix" id="readerComments">

          
          
          
          <h3 class="clearfix">
            <div style="float:left;">
              Comments 
            </div>
            
          </h3>
        </div>
        
        
        <div id="Comments_commentContent" class="commentContent">
          
        </div>
        

          
        <hr />

        

        
          <p class="notice">Comments are closed.
            
          </p>
          

        
      </div><!-- comments -->
      <script type="text/javascript">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</script>
    
  









  
  
      <div id="LatestInCategory" class="SpanningFeature ContentDefault ">
        <h3 class="latestnews"><span class="headingText">Latest in News</span></h3>
        <ul class="moduleList ui list grouped expanded">
    
    
    <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/immigration-finds-some-common-ground-in-local-survey/Content?oid=11090550">
        <img src="https://media2.fdncms.com/rochester/imager/u/review/11090554/forum_dandc.jpg"
             alt="Immigration finds some common ground in local survey"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/immigration-finds-some-common-ground-in-local-survey/Content?oid=11090550">Immigration finds some common ground in local survey</a>
    </h4>
    <div class="date">Nov 25, 2019 </div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/groups-ask-dinolfo-not-to-sign-first-responder-harassment-law/Content?oid=11080903">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/11080907/jfm_9770.jpg"
             alt="Groups ask Dinolfo not to sign first responder harassment law"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/groups-ask-dinolfo-not-to-sign-first-responder-harassment-law/Content?oid=11080903">Groups ask Dinolfo not to sign first responder harassment law</a>
    </h4>
    <div class="date">Nov 22, 2019 </div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/police-officials-call-for-delay-on-criminal-justice-reforms/Content?oid=11080086">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/11080090/thomas_dougherty.jpg"
             alt="Police officials call for delay on criminal justice reforms"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/police-officials-call-for-delay-on-criminal-justice-reforms/Content?oid=11080086">Police officials call for delay on criminal justice reforms</a>
    </h4>
    <div class="date">Nov 22, 2019 </div>
  </li>
    
  
        
            <li class="l0 storyItem more">
              <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?category=2124545" class="more">More &raquo;</a>
            </li>
          </ul>
        
      </div>
    










  

  

  
    <div id="MorebyThisAuthorWrapper" class="SpanningFeature ContentDefault Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="SpanningFeature ContentDefault ">
            <h3><span class="headingText">More by Randy Gorbman</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/immigration-finds-some-common-ground-in-local-survey/Content?oid=11090550">
        <img src="https://media2.fdncms.com/rochester/imager/u/review/11090554/forum_dandc.jpg"
             alt="Immigration finds some common ground in local survey"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/immigration-finds-some-common-ground-in-local-survey/Content?oid=11090550">Immigration finds some common ground in local survey</a>
    </h4>
    <div class="date">Nov 25, 2019 </div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/city-school-officials-look-at-cutting-teaching-positions/Content?oid=11039586">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/11039589/finance_committee_meeting.jpg"
             alt="City school officials look at cutting teaching positions"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/city-school-officials-look-at-cutting-teaching-positions/Content?oid=11039586">City school officials look at cutting teaching positions</a>
    </h4>
    <div class="date">Nov 12, 2019 </div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/four-city-schools-in-receivership-show-progress/Content?oid=11021224">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/11021401/easthigh_sidebar.jpg"
             alt="Four city schools in receivership show improvement"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/four-city-schools-in-receivership-show-progress/Content?oid=11021224">Four city schools in receivership show improvement</a>
    </h4>
    <div class="date">Nov  8, 2019 </div>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives?author=9120774" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  










  

  
    
        <div id="PeopleWhoLiked" class="SpanningFeature ContentDefault ">
          <h3><span class="headingText">Readers also liked&hellip;</span></h3>
          <ul>
      
      
      
      <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/parkinsons-cannabis-and-hope/Content?oid=6235237">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/6235236/homefeatured.gif"
             alt="Parkinson&#39;s, cannabis, and hope"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/parkinsons-cannabis-and-hope/Content?oid=6235237">Parkinson's, cannabis, and hope</a>
    </h4>
    <div class="date">Apr 25, 2018 </div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/ur-laser-lab-survives-trump-threat-stays-in-energy-race/Content?oid=6305247">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/6305246/homefeatured.jpg"
             alt="UR laser lab survives Trump threat, stays in energy race"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/ur-laser-lab-survives-trump-threat-stays-in-energy-race/Content?oid=6305247">UR laser lab survives Trump threat, stays in energy race</a>
    </h4>
    <div class="date">May  2, 2018 </div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      
      <a href="https://www.rochestercitynewspaper.com/rochester/spirituals-show-sparks-controversy/Content?oid=7758539">
        <img src="https://media1.fdncms.com/rochester/imager/u/review/7758401/news1-2.jpg"
             alt="Spirituals show sparks controversy"
             width=""
             height=""
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.rochestercitynewspaper.com/rochester/spirituals-show-sparks-controversy/Content?oid=7758539">Spirituals show sparks controversy</a>
    </h4>
    <div class="date">Aug 28, 2018 </div>
  </li>
      
      
    
          </ul>
        </div>
      
               

      </div><!-- gridSpanningFeature2 -->

      <div id="gridColumnContainer" class="clearfix">

        <div id="gridMainColumn1">
          
        </div><!-- gridMainColumn1 -->
        
        <div id="gridMainColumn2">
          
        </div><!-- gridMainColumn2 -->

      </div><!-- end gridColumnContainer -->

    </div><!-- end gridFrame -->

    <div id="gridRightColumn">   
      <div id="gridSpanningIsland">
        




  

  

  
  

  
  

  
     

     

  
  

  
  


  

  
  
  


  

  



  

  

  
  



<div id="BoxAd1" class="SpanningIsland ContentDefault Ad MediumRectangle">
  <!-- /1843875/CITY_MED_RECT_1 -->
          <div id="div-gpt-ad-city_med_rect_1" style="" data-content-type="ad" data-slot="/1843875/CITY_MED_RECT_1" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-city_med_rect_1');
                });
              </script>
          </div>
</div>





















<div id="EventChooser" class="SpanningIsland ContentDefault ">
  <h3>Browse Listings</h3>

  <div class="tabs">
    <div class="tabCurrent tabLeft"><a href="#">Events</a></div>
    <div class="tabBack tabRight"><a href="#">Music</a></div>
  </div>
  <div class="clear"><!-- clear --></div>


  
  

  <div id="calendarBody-events" class="eventSearchBody" >
    <form name="eventSearchForm" method="get" action="https://www.rochestercitynewspaper.com/rochester/EventSearch">
      <select name="narrowByDate">
    <option value="">-All Dates-</option>
    
    
      
      
        
        
          <option value="2019-11-25" selected="selected">Monday, November 25</option>
        
      
        
        
          <option value="2019-11-26">Tuesday, November 26</option>
        
      
        
        
          <option value="2019-11-27">Wednesday, November 27</option>
        
      
        
        
          <option value="2019-11-28">Thursday, November 28</option>
        
      
        
        
          <option value="2019-11-29">Friday, November 29</option>
        
      
        
        
          <option value="2019-11-30">Saturday, November 30</option>
        
      
        
        
          <option value="2019-12-01">Sunday, December  1</option>
        
      
        
        
          <option value="2019-12-02">Monday, December  2</option>
        
      
        
        
          <option value="2019-12-03">Tuesday, December  3</option>
        
      
        
        
          <option value="2019-12-04">Wednesday, December  4</option>
        
      
        
        
          <option value="2019-12-05">Thursday, December  5</option>
        
      
        
        
          <option value="2019-12-06">Friday, December  6</option>
        
      
        
        
          <option value="2019-12-07">Saturday, December  7</option>
        
      
        
        
          <option value="2019-12-08">Sunday, December  8</option>
        
      
        
        
          <option value="2019-12-09">Monday, December  9</option>
        
      
        
        
          <option value="2019-12-10">Tuesday, December 10</option>
        
      
        
        
          <option value="2019-12-11">Wednesday, December 11</option>
        
      
        
        
          <option value="2019-12-12">Thursday, December 12</option>
        
      
        
        
          <option value="2019-12-13">Friday, December 13</option>
        
      
        
        
          <option value="2019-12-14">Saturday, December 14</option>
        
      
        
        
          <option value="2019-12-15">Sunday, December 15</option>
        
      
        
        
          <option value="2019-12-16">Monday, December 16</option>
        
      
        
        
          <option value="2019-12-17">Tuesday, December 17</option>
        
      
        
        
          <option value="2019-12-18">Wednesday, December 18</option>
        
      
        
        
          <option value="2019-12-19">Thursday, December 19</option>
        
      
        
        
          <option value="2019-12-20">Friday, December 20</option>
        
      
        
        
          <option value="2019-12-21">Saturday, December 21</option>
        
      
        
        
          <option value="2019-12-22">Sunday, December 22</option>
        
      
        
        
          <option value="2019-12-23">Monday, December 23</option>
        
      
        
        
          <option value="2019-12-24">Tuesday, December 24</option>
        
      
        
        
          <option value="2019-12-25">Wednesday, December 25</option>
        
      
    
  </select>

      <select name="eventCategory">
        <option value="">-All Categories-</option>
        
          
            <option value="2124696" >ARTS &amp; PERFORMANCE</option>
          
          
            <option value="2124773" >&nbsp;&nbsp;Art Events</option>
          
        
          
          
            <option value="2124771" >&nbsp;&nbsp;Art Exhibits</option>
          
        
          
          
            <option value="2124772" >&nbsp;&nbsp;Call for Artists</option>
          
        
          
          
            <option value="2390970" >&nbsp;&nbsp;Call for Participants</option>
          
        
          
          
            <option value="2131975" >&nbsp;&nbsp;Comedy</option>
          
        
          
          
            <option value="2124774" >&nbsp;&nbsp;Dance Events</option>
          
        
          
          
            <option value="2124775" >&nbsp;&nbsp;Theater</option>
          
        
          
          
            <option value="2136681" >&nbsp;&nbsp;Theater Audition</option>
          
        
          
            <option value="2124768" >COMMUNITY</option>
          
          
            <option value="2924836" >&nbsp;&nbsp;Activism</option>
          
        
          
          
            <option value="9325826" >&nbsp;&nbsp;Dr. Martin Luther King, Jr. Day</option>
          
        
          
          
            <option value="10190919" >&nbsp;&nbsp;Earth Day</option>
          
        
          
          
            <option value="2124776" >&nbsp;&nbsp;Festivals</option>
          
        
          
          
            <option value="2457927" >&nbsp;&nbsp;Film</option>
          
        
          
          
            <option value="5465873" >&nbsp;&nbsp;Frederick Douglass</option>
          
        
          
          
            <option value="6400527" >&nbsp;&nbsp;Halloween</option>
          
        
          
          
            <option value="2474372" >&nbsp;&nbsp;Holiday</option>
          
        
          
          
            <option value="2124777" >&nbsp;&nbsp;Kids Events</option>
          
        
          
          
            <option value="2392843" >&nbsp;&nbsp;Meetings</option>
          
        
          
          
            <option value="8972602" >&nbsp;&nbsp;New Year&#39;s Eve</option>
          
        
          
          
            <option value="2124778" >&nbsp;&nbsp;Recreation</option>
          
        
          
          
            <option value="2124781" >&nbsp;&nbsp;Special Events</option>
          
        
          
          
            <option value="2124780" >&nbsp;&nbsp;Sports</option>
          
        
          
          
            <option value="2124784" >&nbsp;&nbsp;Workshops</option>
          
        
          
            <option value="2124769" >CULTURE</option>
          
          
            <option value="2124782" >&nbsp;&nbsp;Lectures</option>
          
        
          
          
            <option value="2124783" >&nbsp;&nbsp;Literary Events</option>
          
        
          
          
            <option value="2134033" >&nbsp;&nbsp;Museum Exhibit</option>
          
        
          
            <option value="9154215" >NEW YEAR&#39;S EVE</option>
          
          
            <option value="9154216" >&nbsp;&nbsp;Family</option>
          
        
          
          
            <option value="9154281" >&nbsp;&nbsp;Laughs</option>
          
        
          
          
            <option value="9154282" >&nbsp;&nbsp;On Screen</option>
          
        
          
          
            <option value="9154414" >&nbsp;&nbsp;Outdoors</option>
          
        
          
          
            <option value="9154283" >&nbsp;&nbsp;Revelry</option>
          
        
      </select>

      <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="2134278" >ROCHESTER</option>
        
        <option value="2124863" >&nbsp;&nbsp;City of Rochester</option>
      
        
        <option value="2229831" >&nbsp;&nbsp;College Town</option>
      
        
        <option value="2134282" >&nbsp;&nbsp;19th Ward</option>
      
        
        <option value="2134285" >&nbsp;&nbsp;Alphabet Streets</option>
      
        
        <option value="2134286" >&nbsp;&nbsp;Beechwood</option>
      
        
        <option value="2134287" >&nbsp;&nbsp;Brown Square</option>
      
        
        <option value="2134288" >&nbsp;&nbsp;Browncroft</option>
      
        
        <option value="2134289" >&nbsp;&nbsp;Bull&#39;s Head</option>
      
        
        <option value="2134291" >&nbsp;&nbsp;COTS</option>
      
        
        <option value="2134292" >&nbsp;&nbsp;Charlotte</option>
      
        
        <option value="2134293" >&nbsp;&nbsp;Cobbs Hill</option>
      
        
        <option value="2134294" >&nbsp;&nbsp;Corn Hill</option>
      
        
        <option value="2134295" >&nbsp;&nbsp;East Avenue</option>
      
        
        <option value="2134296" >&nbsp;&nbsp;East End</option>
      
        
        <option value="2134297" >&nbsp;&nbsp;Edgerton</option>
      
        
        <option value="2134298" >&nbsp;&nbsp;Genesee-Jefferson</option>
      
        
        <option value="2134299" >&nbsp;&nbsp;Group 14621</option>
      
        
        <option value="2134300" >&nbsp;&nbsp;Grove Place</option>
      
        
        <option value="2134301" >&nbsp;&nbsp;High Falls</option>
      
        
        <option value="2134302" >&nbsp;&nbsp;Highland Park</option>
      
        
        <option value="2134303" >&nbsp;&nbsp;Homestead Heights</option>
      
        
        <option value="2134304" >&nbsp;&nbsp;JOSANA</option>
      
        
        <option value="2134323" >&nbsp;&nbsp;Lyell-Otis</option>
      
        
        <option value="2134324" >&nbsp;&nbsp;Maplewood</option>
      
        
        <option value="2134325" >&nbsp;&nbsp;Marketview Heights</option>
      
        
        <option value="2134327" >&nbsp;&nbsp;Monroe Village</option>
      
        
        <option value="2125238" >&nbsp;&nbsp;Mount Hope</option>
      
        
        <option value="2124698" >&nbsp;&nbsp;Neighborhood of the Arts</option>
      
        
        <option value="2134329" >&nbsp;&nbsp;North Winton Village</option>
      
        
        <option value="2134330" >&nbsp;&nbsp;Northland-Lyceum</option>
      
        
        <option value="2125223" >&nbsp;&nbsp;Park Avenue</option>
      
        
        <option value="2134331" >&nbsp;&nbsp;Pearl-Meigs-Monroe</option>
      
        
        <option value="2134332" >&nbsp;&nbsp;Plymouth-Exchange</option>
      
        
        <option value="2134333" >&nbsp;&nbsp;South Wedge</option>
      
        
        <option value="2134343" >&nbsp;&nbsp;St. Paul Quarter</option>
      
        
        <option value="2134334" >&nbsp;&nbsp;Susan B. Anthony</option>
      
        
        <option value="2134336" >&nbsp;&nbsp;Swillburg</option>
      
        
        <option value="2134337" >&nbsp;&nbsp;U.N.I.T.</option>
      
        
        <option value="2134338" >&nbsp;&nbsp;Upper Falls</option>
      
        
        <option value="2134339" >&nbsp;&nbsp;Upper Monroe Avenue</option>
      
        
        <option value="2134340" >&nbsp;&nbsp;Upper Mount Hope</option>
      
        
        <option value="2134341" >&nbsp;&nbsp;Wadsworth Square</option>
      
        
        <option value="2216396" >&nbsp;&nbsp;Laurelton</option>
      
        
          <option value="2134317" >SUBURBS</option>
        
        <option value="4446507" >&nbsp;&nbsp;Caledonia</option>
      
        
        <option value="2184747" >&nbsp;&nbsp;Albion</option>
      
        
        <option value="2142743" >&nbsp;&nbsp;Alton</option>
      
        
        <option value="2134491" >&nbsp;&nbsp;Auburn</option>
      
        
        <option value="2201937" >&nbsp;&nbsp;Aurora</option>
      
        
        <option value="2161507" >&nbsp;&nbsp;Avon</option>
      
        
        <option value="2131961" >&nbsp;&nbsp;Batavia</option>
      
        
        <option value="11064499" >&nbsp;&nbsp;Bloomfield</option>
      
        
        <option value="2131964" >&nbsp;&nbsp;Brighton</option>
      
        
        <option value="2125582" >&nbsp;&nbsp;Brockport</option>
      
        
        <option value="2136431" >&nbsp;&nbsp;Bushnell&#39;s Basin</option>
      
        
        <option value="2125199" >&nbsp;&nbsp;Canandaigua</option>
      
        
        <option value="2134250" >&nbsp;&nbsp;Chili</option>
      
        
        <option value="2134261" >&nbsp;&nbsp;Churchville</option>
      
        
        <option value="2216252" >&nbsp;&nbsp;Clifton Springs</option>
      
        
        <option value="2250745" >&nbsp;&nbsp;Corning</option>
      
        
        <option value="2125263" >&nbsp;&nbsp;Darien</option>
      
        
        <option value="2125260" >&nbsp;&nbsp;East Rochester</option>
      
        
        <option value="2125282" >&nbsp;&nbsp;Fairport</option>
      
        
        <option value="2136578" >&nbsp;&nbsp;Farmington</option>
      
        
        <option value="2125274" >&nbsp;&nbsp;Gates</option>
      
        
        <option value="2139668" >&nbsp;&nbsp;Geneseo</option>
      
        
        <option value="2125585" >&nbsp;&nbsp;Geneva</option>
      
        
        <option value="2134080" >&nbsp;&nbsp;Greece</option>
      
        
        <option value="2134255" >&nbsp;&nbsp;Hamlin</option>
      
        
        <option value="2125267" >&nbsp;&nbsp;Henrietta</option>
      
        
        <option value="2125298" >&nbsp;&nbsp;Hilton</option>
      
        
        <option value="2227154" >&nbsp;&nbsp;Holley</option>
      
        
        <option value="2331864" >&nbsp;&nbsp;Honeoye</option>
      
        
        <option value="2125347" >&nbsp;&nbsp;Honeoye Falls</option>
      
        
        <option value="2138112" >&nbsp;&nbsp;Interlaken</option>
      
        
        <option value="2125731" >&nbsp;&nbsp;Irondequoit</option>
      
        
        <option value="2125230" >&nbsp;&nbsp;Letchworth</option>
      
        
        <option value="2141052" >&nbsp;&nbsp;Lima</option>
      
        
        <option value="2138244" >&nbsp;&nbsp;Lyons</option>
      
        
        <option value="2134365" >&nbsp;&nbsp;Macedon</option>
      
        
        <option value="2139353" >&nbsp;&nbsp;Medina</option>
      
        
        <option value="2134267" >&nbsp;&nbsp;Mendon</option>
      
        
        <option value="2144826" >&nbsp;&nbsp;Middlesex</option>
      
        
        <option value="2125566" >&nbsp;&nbsp;Mumford</option>
      
        
        <option value="2134495" >&nbsp;&nbsp;Naples</option>
      
        
        <option value="2138341" >&nbsp;&nbsp;North Chili</option>
      
        
        <option value="2134257" >&nbsp;&nbsp;Ogden</option>
      
        
        <option value="9863757" >&nbsp;&nbsp;Palmyra</option>
      
        
        <option value="2125270" >&nbsp;&nbsp;Park Point</option>
      
        
        <option value="2131978" >&nbsp;&nbsp;Penfield</option>
      
        
        <option value="2139627" >&nbsp;&nbsp;Penn Yan</option>
      
        
        <option value="2125579" >&nbsp;&nbsp;Perinton</option>
      
        
        <option value="2144625" >&nbsp;&nbsp;Perry</option>
      
        
        <option value="2255802" >&nbsp;&nbsp;Phelps</option>
      
        
        <option value="2125244" >&nbsp;&nbsp;Pittsford</option>
      
        
        <option value="2125461" >&nbsp;&nbsp;Pultneyville</option>
      
        
        <option value="2286124" >&nbsp;&nbsp;Romulus</option>
      
        
        <option value="2134266" >&nbsp;&nbsp;Rush</option>
      
        
        <option value="2125783" >&nbsp;&nbsp;Scottsville</option>
      
        
        <option value="2138091" >&nbsp;&nbsp;Seneca Falls</option>
      
        
        <option value="2138131" >&nbsp;&nbsp;Shortsville</option>
      
        
        <option value="2125540" >&nbsp;&nbsp;Sodus Point</option>
      
        
        <option value="2134258" >&nbsp;&nbsp;Spencerport</option>
      
        
        <option value="2142982" >&nbsp;&nbsp;Sterling</option>
      
        
        <option value="2134275" >&nbsp;&nbsp;Sweden</option>
      
        
        <option value="2125287" >&nbsp;&nbsp;Victor</option>
      
        
        <option value="2134268" >&nbsp;&nbsp;Village of Pittsford</option>
      
        
        <option value="2134270" >&nbsp;&nbsp;Village of Webster</option>
      
        
        <option value="2125277" >&nbsp;&nbsp;Webster</option>
      
        
        <option value="2134272" >&nbsp;&nbsp;Wheatland</option>
      
        
        <option value="2146479" >&nbsp;&nbsp;Pavillon</option>
      
        
        <option value="2247719" >&nbsp;&nbsp;Livonia</option>
      
    
  </select>
      <input type="text" size="18" name="keywords" title="Enter keyword" class="text" value="" />
      <input type="hidden" name="ongoing" value="Timely" />
      <input type="submit" value="go" />
    </form>
      <a href="https://posting.rochestercitynewspaper.com/rochester/Events/AddEvent">Submit an event</a>
  </div>


  

  <div id="calendarBody-music" class="eventSearchBody" style="display:none">
    <form name="musicEventSearchForm" method="get" action="https://www.rochestercitynewspaper.com/rochester/EventSearch">
      <input type="hidden" name="eventSection" value="2124770" />

      <select name="narrowByDate">
    <option value="">-All Dates-</option>
    
    
      
      
        
        
          <option value="2019-11-25" selected="selected">Monday, November 25</option>
        
      
        
        
          <option value="2019-11-26">Tuesday, November 26</option>
        
      
        
        
          <option value="2019-11-27">Wednesday, November 27</option>
        
      
        
        
          <option value="2019-11-28">Thursday, November 28</option>
        
      
        
        
          <option value="2019-11-29">Friday, November 29</option>
        
      
        
        
          <option value="2019-11-30">Saturday, November 30</option>
        
      
        
        
          <option value="2019-12-01">Sunday, December  1</option>
        
      
        
        
          <option value="2019-12-02">Monday, December  2</option>
        
      
        
        
          <option value="2019-12-03">Tuesday, December  3</option>
        
      
        
        
          <option value="2019-12-04">Wednesday, December  4</option>
        
      
        
        
          <option value="2019-12-05">Thursday, December  5</option>
        
      
        
        
          <option value="2019-12-06">Friday, December  6</option>
        
      
        
        
          <option value="2019-12-07">Saturday, December  7</option>
        
      
        
        
          <option value="2019-12-08">Sunday, December  8</option>
        
      
        
        
          <option value="2019-12-09">Monday, December  9</option>
        
      
        
        
          <option value="2019-12-10">Tuesday, December 10</option>
        
      
        
        
          <option value="2019-12-11">Wednesday, December 11</option>
        
      
        
        
          <option value="2019-12-12">Thursday, December 12</option>
        
      
        
        
          <option value="2019-12-13">Friday, December 13</option>
        
      
        
        
          <option value="2019-12-14">Saturday, December 14</option>
        
      
        
        
          <option value="2019-12-15">Sunday, December 15</option>
        
      
        
        
          <option value="2019-12-16">Monday, December 16</option>
        
      
        
        
          <option value="2019-12-17">Tuesday, December 17</option>
        
      
        
        
          <option value="2019-12-18">Wednesday, December 18</option>
        
      
        
        
          <option value="2019-12-19">Thursday, December 19</option>
        
      
        
        
          <option value="2019-12-20">Friday, December 20</option>
        
      
        
        
          <option value="2019-12-21">Saturday, December 21</option>
        
      
        
        
          <option value="2019-12-22">Sunday, December 22</option>
        
      
        
        
          <option value="2019-12-23">Monday, December 23</option>
        
      
        
        
          <option value="2019-12-24">Tuesday, December 24</option>
        
      
        
        
          <option value="2019-12-25">Wednesday, December 25</option>
        
      
    
  </select>

      <select name="eventCategory">
        <option value="">-All Categories-</option>
        
          <option value="2124786" >Acoustic/Folk</option>
        
          <option value="5494922" >Americana</option>
        
          <option value="2125068" >Blues</option>
        
          <option value="2125069" >Classical</option>
        
          <option value="8025273" >Contemporary Classical</option>
        
          <option value="2125393" >Country</option>
        
          <option value="2125070" >DJ/Electronic</option>
        
          <option value="8486889" >Halloween Theme</option>
        
          <option value="2125201" >Hip-Hop/Rap</option>
        
          <option value="9546606" >Indie</option>
        
          <option value="8953008" >Industrial</option>
        
          <option value="10887782" >Jam Band</option>
        
          <option value="2125057" >Jazz</option>
        
          <option value="2125071" >Karaoke</option>
        
          <option value="2392846" >Metal</option>
        
          <option value="9155532" >New Year&#39;s</option>
        
          <option value="7534692" >Noise/Experimental</option>
        
          <option value="2125072" >Open Mic</option>
        
          <option value="2124790" >Pop/Rock</option>
        
          <option value="5557259" >Punk/Hardcore</option>
        
          <option value="2125073" >R&amp;B/ Soul</option>
        
          <option value="9977503" >Record Store Day</option>
        
          <option value="2125074" >Reggae</option>
        
          <option value="7610550" >Rockabilly</option>
        
          <option value="10897401" >Seasonal</option>
        
          <option value="9607901" >Ska</option>
        
          <option value="2392844" >Traditional</option>
        
          <option value="9435273" >Tropical</option>
        
          <option value="9948971" >Various</option>
        
          <option value="2392845" >Vocals</option>
        
          <option value="9033633" >World</option>
        
          <option value="5494919" >Zydeco</option>
        
      </select>

      <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        
          <option value="2134278" >ROCHESTER</option>
        
        <option value="2124863" >&nbsp;&nbsp;City of Rochester</option>
      
        
        <option value="2229831" >&nbsp;&nbsp;College Town</option>
      
        
        <option value="2134282" >&nbsp;&nbsp;19th Ward</option>
      
        
        <option value="2134285" >&nbsp;&nbsp;Alphabet Streets</option>
      
        
        <option value="2134286" >&nbsp;&nbsp;Beechwood</option>
      
        
        <option value="2134287" >&nbsp;&nbsp;Brown Square</option>
      
        
        <option value="2134288" >&nbsp;&nbsp;Browncroft</option>
      
        
        <option value="2134289" >&nbsp;&nbsp;Bull&#39;s Head</option>
      
        
        <option value="2134291" >&nbsp;&nbsp;COTS</option>
      
        
        <option value="2134292" >&nbsp;&nbsp;Charlotte</option>
      
        
        <option value="2134293" >&nbsp;&nbsp;Cobbs Hill</option>
      
        
        <option value="2134294" >&nbsp;&nbsp;Corn Hill</option>
      
        
        <option value="2134295" >&nbsp;&nbsp;East Avenue</option>
      
        
        <option value="2134296" >&nbsp;&nbsp;East End</option>
      
        
        <option value="2134297" >&nbsp;&nbsp;Edgerton</option>
      
        
        <option value="2134298" >&nbsp;&nbsp;Genesee-Jefferson</option>
      
        
        <option value="2134299" >&nbsp;&nbsp;Group 14621</option>
      
        
        <option value="2134300" >&nbsp;&nbsp;Grove Place</option>
      
        
        <option value="2134301" >&nbsp;&nbsp;High Falls</option>
      
        
        <option value="2134302" >&nbsp;&nbsp;Highland Park</option>
      
        
        <option value="2134303" >&nbsp;&nbsp;Homestead Heights</option>
      
        
        <option value="2134304" >&nbsp;&nbsp;JOSANA</option>
      
        
        <option value="2134323" >&nbsp;&nbsp;Lyell-Otis</option>
      
        
        <option value="2134324" >&nbsp;&nbsp;Maplewood</option>
      
        
        <option value="2134325" >&nbsp;&nbsp;Marketview Heights</option>
      
        
        <option value="2134327" >&nbsp;&nbsp;Monroe Village</option>
      
        
        <option value="2125238" >&nbsp;&nbsp;Mount Hope</option>
      
        
        <option value="2124698" >&nbsp;&nbsp;Neighborhood of the Arts</option>
      
        
        <option value="2134329" >&nbsp;&nbsp;North Winton Village</option>
      
        
        <option value="2134330" >&nbsp;&nbsp;Northland-Lyceum</option>
      
        
        <option value="2125223" >&nbsp;&nbsp;Park Avenue</option>
      
        
        <option value="2134331" >&nbsp;&nbsp;Pearl-Meigs-Monroe</option>
      
        
        <option value="2134332" >&nbsp;&nbsp;Plymouth-Exchange</option>
      
        
        <option value="2134333" >&nbsp;&nbsp;South Wedge</option>
      
        
        <option value="2134343" >&nbsp;&nbsp;St. Paul Quarter</option>
      
        
        <option value="2134334" >&nbsp;&nbsp;Susan B. Anthony</option>
      
        
        <option value="2134336" >&nbsp;&nbsp;Swillburg</option>
      
        
        <option value="2134337" >&nbsp;&nbsp;U.N.I.T.</option>
      
        
        <option value="2134338" >&nbsp;&nbsp;Upper Falls</option>
      
        
        <option value="2134339" >&nbsp;&nbsp;Upper Monroe Avenue</option>
      
        
        <option value="2134340" >&nbsp;&nbsp;Upper Mount Hope</option>
      
        
        <option value="2134341" >&nbsp;&nbsp;Wadsworth Square</option>
      
        
        <option value="2216396" >&nbsp;&nbsp;Laurelton</option>
      
        
          <option value="2134317" >SUBURBS</option>
        
        <option value="4446507" >&nbsp;&nbsp;Caledonia</option>
      
        
        <option value="2184747" >&nbsp;&nbsp;Albion</option>
      
        
        <option value="2142743" >&nbsp;&nbsp;Alton</option>
      
        
        <option value="2134491" >&nbsp;&nbsp;Auburn</option>
      
        
        <option value="2201937" >&nbsp;&nbsp;Aurora</option>
      
        
        <option value="2161507" >&nbsp;&nbsp;Avon</option>
      
        
        <option value="2131961" >&nbsp;&nbsp;Batavia</option>
      
        
        <option value="11064499" >&nbsp;&nbsp;Bloomfield</option>
      
        
        <option value="2131964" >&nbsp;&nbsp;Brighton</option>
      
        
        <option value="2125582" >&nbsp;&nbsp;Brockport</option>
      
        
        <option value="2136431" >&nbsp;&nbsp;Bushnell&#39;s Basin</option>
      
        
        <option value="2125199" >&nbsp;&nbsp;Canandaigua</option>
      
        
        <option value="2134250" >&nbsp;&nbsp;Chili</option>
      
        
        <option value="2134261" >&nbsp;&nbsp;Churchville</option>
      
        
        <option value="2216252" >&nbsp;&nbsp;Clifton Springs</option>
      
        
        <option value="2250745" >&nbsp;&nbsp;Corning</option>
      
        
        <option value="2125263" >&nbsp;&nbsp;Darien</option>
      
        
        <option value="2125260" >&nbsp;&nbsp;East Rochester</option>
      
        
        <option value="2125282" >&nbsp;&nbsp;Fairport</option>
      
        
        <option value="2136578" >&nbsp;&nbsp;Farmington</option>
      
        
        <option value="2125274" >&nbsp;&nbsp;Gates</option>
      
        
        <option value="2139668" >&nbsp;&nbsp;Geneseo</option>
      
        
        <option value="2125585" >&nbsp;&nbsp;Geneva</option>
      
        
        <option value="2134080" >&nbsp;&nbsp;Greece</option>
      
        
        <option value="2134255" >&nbsp;&nbsp;Hamlin</option>
      
        
        <option value="2125267" >&nbsp;&nbsp;Henrietta</option>
      
        
        <option value="2125298" >&nbsp;&nbsp;Hilton</option>
      
        
        <option value="2227154" >&nbsp;&nbsp;Holley</option>
      
        
        <option value="2331864" >&nbsp;&nbsp;Honeoye</option>
      
        
        <option value="2125347" >&nbsp;&nbsp;Honeoye Falls</option>
      
        
        <option value="2138112" >&nbsp;&nbsp;Interlaken</option>
      
        
        <option value="2125731" >&nbsp;&nbsp;Irondequoit</option>
      
        
        <option value="2125230" >&nbsp;&nbsp;Letchworth</option>
      
        
        <option value="2141052" >&nbsp;&nbsp;Lima</option>
      
        
        <option value="2138244" >&nbsp;&nbsp;Lyons</option>
      
        
        <option value="2134365" >&nbsp;&nbsp;Macedon</option>
      
        
        <option value="2139353" >&nbsp;&nbsp;Medina</option>
      
        
        <option value="2134267" >&nbsp;&nbsp;Mendon</option>
      
        
        <option value="2144826" >&nbsp;&nbsp;Middlesex</option>
      
        
        <option value="2125566" >&nbsp;&nbsp;Mumford</option>
      
        
        <option value="2134495" >&nbsp;&nbsp;Naples</option>
      
        
        <option value="2138341" >&nbsp;&nbsp;North Chili</option>
      
        
        <option value="2134257" >&nbsp;&nbsp;Ogden</option>
      
        
        <option value="9863757" >&nbsp;&nbsp;Palmyra</option>
      
        
        <option value="2125270" >&nbsp;&nbsp;Park Point</option>
      
        
        <option value="2131978" >&nbsp;&nbsp;Penfield</option>
      
        
        <option value="2139627" >&nbsp;&nbsp;Penn Yan</option>
      
        
        <option value="2125579" >&nbsp;&nbsp;Perinton</option>
      
        
        <option value="2144625" >&nbsp;&nbsp;Perry</option>
      
        
        <option value="2255802" >&nbsp;&nbsp;Phelps</option>
      
        
        <option value="2125244" >&nbsp;&nbsp;Pittsford</option>
      
        
        <option value="2125461" >&nbsp;&nbsp;Pultneyville</option>
      
        
        <option value="2286124" >&nbsp;&nbsp;Romulus</option>
      
        
        <option value="2134266" >&nbsp;&nbsp;Rush</option>
      
        
        <option value="2125783" >&nbsp;&nbsp;Scottsville</option>
      
        
        <option value="2138091" >&nbsp;&nbsp;Seneca Falls</option>
      
        
        <option value="2138131" >&nbsp;&nbsp;Shortsville</option>
      
        
        <option value="2125540" >&nbsp;&nbsp;Sodus Point</option>
      
        
        <option value="2134258" >&nbsp;&nbsp;Spencerport</option>
      
        
        <option value="2142982" >&nbsp;&nbsp;Sterling</option>
      
        
        <option value="2134275" >&nbsp;&nbsp;Sweden</option>
      
        
        <option value="2125287" >&nbsp;&nbsp;Victor</option>
      
        
        <option value="2134268" >&nbsp;&nbsp;Village of Pittsford</option>
      
        
        <option value="2134270" >&nbsp;&nbsp;Village of Webster</option>
      
        
        <option value="2125277" >&nbsp;&nbsp;Webster</option>
      
        
        <option value="2134272" >&nbsp;&nbsp;Wheatland</option>
      
        
        <option value="2146479" >&nbsp;&nbsp;Pavillon</option>
      
        
        <option value="2247719" >&nbsp;&nbsp;Livonia</option>
      
    
  </select>

      <input type="text" size="18" name="keywords" title="Enter keyword" class="text" value="" />
      <input type="submit" value="go" />
    </form>

    <a href="https://posting.rochestercitynewspaper.com/rochester/Events/AddEvent">Submit an event</a>
  </div>

</div>









<script type="text/javascript"><!--
  Event.observe(document, "dom:loaded", function () {
      dnSetupTabGroup(
          $$("#EventChooser div.tabs>div"),
          $$("#EventChooser div.eventSearchBody"),
          "tabCurrent", "tabBack", 0
      );

      // Deactivate links.
      $$("#EventChooser div.tabs>div a").each(function (a) {
          a.onclick = function () { return false; };
      });
  });
//--></script>


<div id="Ad_300x100_2" class="SpanningIsland ContentDefault ShortRectangle Ad">
  <!-- /1843875/CITY_Sitewide_DD_Ad -->
          <div id="div-gpt-ad-city_sitewide_dd_ad" style="" data-content-type="ad" data-slot="/1843875/CITY_Sitewide_DD_Ad" data-output="asynchronous" data-width="300" data-height="100">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-city_sitewide_dd_ad');
                });
              </script>
          </div>
</div>





  











<div id="EventsToday" class="SpanningIsland ContentDefault ">

  <div class="headerBar">
    <a href="https://www.rochestercitynewspaper.com/rochester/EventSearch"><h2>Upcoming Events</h2></a>
  </div>
  <div class="calendarDays">
    <a class="calCurrent" href="https://www.rochestercitynewspaper.com/rochester/EventSearch?narrowByDate=2019-11-25%2004%3A00%3A00">Mon<br /><span>25</span></a>
    
      <a class="calDay" href="https://www.rochestercitynewspaper.com/rochester/EventSearch?narrowByDate=2019-11-26%2004%3A00%3A00">Tue<br /><span>26</span></a>
    
      <a class="calDay" href="https://www.rochestercitynewspaper.com/rochester/EventSearch?narrowByDate=2019-11-27%2004%3A00%3A00">Wed<br /><span>27</span></a>
    
      <a class="calDay" href="https://www.rochestercitynewspaper.com/rochester/EventSearch?narrowByDate=2019-11-28%2004%3A00%3A00">Thu<br /><span>28</span></a>
    
      <a class="calDay" href="https://www.rochestercitynewspaper.com/rochester/EventSearch?narrowByDate=2019-11-29%2004%3A00%3A00">Fri<br /><span>29</span></a>
    
      <a class="calDay" href="https://www.rochestercitynewspaper.com/rochester/EventSearch?narrowByDate=2019-11-30%2004%3A00%3A00">Sat<br /><span>30</span></a>
    
      <a class="calDay last" href="https://www.rochestercitynewspaper.com/rochester/EventSearch?narrowByDate=2019-12-01%2004%3A00%3A00">Sun<br /><span> 1</span></a>
    
  </div>

  

  

  
  
    <div class="storyItem">
     
     
     <h4 class="headline"><a href="https://www.rochestercitynewspaper.com/rochester/boys-dont-cry-1999/Event?oid=11064490">"Boys Don't Cry" (1999)</a>  <span class="smaller">@ Little Theatre</span></h4>
     
   </div>
  
    <div class="storyItem">
     
     
     <h4 class="headline"><a href="https://www.rochestercitynewspaper.com/rochester/indie-lens-pop-up-the-first-rainbow-coalition/Event?oid=11064491">Indie Lens Pop-Up: The First Rainbow Coalition"</a>  <span class="smaller">@ Little Theatre</span></h4>
     
   </div>
  
    <div class="storyItem">
     
     
     <h4 class="headline"><a href="https://www.rochestercitynewspaper.com/rochester/jujiro-1928/Event?oid=11064695">"Jujiro" (1928)</a>  <span class="smaller">@ Dryden Theatre</span></h4>
     
   </div>
  

    <p class="more"><a href="https://www.rochestercitynewspaper.com/rochester/EventSearch?narrowByDate=today">View all of today's events</a> &raquo;</p>

  <p class="submitLink"><a href="https://posting.rochestercitynewspaper.com/rochester/Events/AddEvent">&raquo; SUBMIT AN EVENT &laquo;</a></p>
</div><div id="BoxAd2" class="SpanningIsland ContentDefault Ad MediumRectangle">
  <!-- /1843875/CITY_MED_RECT_2 -->
          <div id="div-gpt-ad-city_med_rect_2" style="" data-content-type="ad" data-slot="/1843875/CITY_MED_RECT_2" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-city_med_rect_2');
                });
              </script>
          </div>
</div><div id="Ad_300x100_1" class="SpanningIsland ContentDefault ShortRectangle Ad">
  <!-- /1843875/CITY_Sitewide_UR_Ad -->
          <div id="div-gpt-ad-city_sitewide_ur_ad" style="" data-content-type="ad" data-slot="/1843875/CITY_Sitewide_UR_Ad" data-output="asynchronous" data-width="300" data-height="100">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-city_sitewide_ur_ad');
                });
              </script>
          </div>
</div>


    

    <div id="GuidesandSpecialIssues" class="SpanningIsland ContentDefault  GuideSelector">
      <h3>Guides & Special Issues</h3>     
  
  

  
    <div id="guide-11068254" class="guide ">
      <a href="/rochester/bah-humbug/Content?oid=11068249" target="_self"><h4>Holiday Guide 2019</h4></a>
      <a href="/rochester/bah-humbug/Content?oid=11068249" target="_self"><img src="https://media2.fdncms.com/rochester/imager/u/cover/11068253/cn_section-cover.jpg" alt=""/></a>
    </div>
  

  

  

  
    
  

  

  

  
    
  

  

  

  
    
  

  

  

  
    
  

  

  

  
    
  

  

  

  
    
  

  

      <ul>
      <h4>Other Recent Guides:</h4>
      
        <li> <a href="/rochester/explore-the-best-of-rochester/Content?oid=10946890" target=_"self">Best of Rochester 2019</a></li>
      
        <li> <a href="/rochester/fall-guide-2019/Content?oid=10829680" target=_"self">Fall Guide19</a></li>
      
        <li> <a href="/rochester/fringe-festival-guide-2019/Content?oid=10770875" target=_"self">Rochester Fringe Festival 2019</a></li>
      
        <li> <a href="/rochester/life-beyond-the-campus/Content?oid=10740888" target=_"self">CITY U 2019</a></li>
      
        <li> <a href="/rochester/jazz-festival-guide-2019/Content?oid=10434165" target=_"self">Jazz Festival 2019</a></li>
      
        <li> <a href="/rochester/dont-bug-out/Content?oid=10374188" target=_"self">Summer Guide 2019</a></li>
      
      </ul>
    </div>
  




    <div id="ThisWeeksIssue" class="SpanningIsland ContentDefault  clearfix">
    <h3>This Week's Issue</h3>     
  
  

  <div class="ThisWeekHeader">
    <div class="ThisIssueDate">
      <a href="https://www.rochestercitynewspaper.com/rochester/IssueArchives?issue=11063555">
        November 20-26, 2019
      </a>
    </div>  
 
  
    <div class="digEdition">
      <a href="https://issuu.com/roccitynews/docs/cn_issuu_11-20-19" target="_blank">View PDF</a>
    </div>
  

</div>
<div class="ThisWeekLeft">
  
    <div id="issueCover">
      <a href="https://www.rochestercitynewspaper.com/rochester/IssueArchives?issue=11063555"><img src="/imager/b/cover/11063555/011a/CN_Cover_Holiday-Guide_ROP.jpg" alt="Issue Cover" /></a>
    </div>
  
  </div>

  <div id="CoverStory">
    
        <div class="specialissuehead">Cover Story:</div>
      
      
      <a href="https://www.rochestercitynewspaper.com/rochester/bah-humbug/Content?oid=11068249">Bah! Humbug!</a><br>
      We're embracing our "grim and depressing" city during the darkest and gloomiest holiday months with what we think is a realistic amount of glee, seasoned with plenty of snark. 
      <a href="https://www.rochestercitynewspaper.com/rochester/bah-humbug/Content?oid=11068249" class="more">read more ...</a>
  		      
    
  </div><!-- #SpecialIssues -->

  <div id="coverGalleryLink">
    <form name="issueSearchForm" method="get" action="https://www.rochestercitynewspaper.com/rochester/IssueArchives">
      <a href="https://www.rochestercitynewspaper.com/rochester/IssueArchives">Cover Gallery &raquo;</a>
      <select name="issue" onchange="submit();">
        <option value="">Browse Issue by Date</option>
        
           <option value="11063555">November 20, 2019</option>
        
           <option value="11038473">November 13, 2019</option>
        
           <option value="11005146">November  6, 2019</option>
        
           <option value="10976691">October 30, 2019</option>
        
           <option value="10946887">October 23, 2019</option>
        
           <option value="10926378">October 16, 2019</option>
        
           <option value="10917492">October  9, 2019</option>
        
           <option value="10887981">October  2, 2019</option>
        
           <option value="10859718">September 25, 2019</option>
        
           <option value="10829679">September 18, 2019</option>
        
        <option value="">More...</option>
      </select>
    </form>
  </div><!-- #coverGalleryLink --> 

  

    </div><!-- #ThisWeeksIssue -->
    <div class="clear"></div>
  


      </div><!-- end gridSpanningIsland -->  
     
      <div id="gridMainSidebar">
        
      </div><!-- end gridMainSidebar -->

      <div id="gridAdSidebar">
        
      </div><!-- end gridAdSidebar -->
      
      <div id="gridBottomSidebar">
        <div id="TwitterWidgetRochester" class="MainSidebar ContentDefault ">
  <h3>Tweets @RocCityNews</h3>
  <a class="twitter-timeline"  href="https://twitter.com/roccitynews"  data-widget-id="345637461659095041" data-chrome="noheader nofooter noborders" width="310" height="300">Tweets by @roccitynews</a>
  <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
</div>
      </div>
    </div><!-- end gridRightColumn -->
    
    <!-- Footer -->
    <div id="gridFooter">
      


    <div id="FooterNavigation" class="GlobalFooter ContentDefault ">
      <ul>
  
  
  <li class="">
    <a href="https://www.rochestercitynewspaper.com/rochester/ArticleArchives" target="_self">
      
        Article Archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.rochestercitynewspaper.com/rochester/IssueArchives" target="_self">
      
        Issue Archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="http://www.issuu.com/roccitynews" target="_blank">
      
        PDF Archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.rochestercitynewspaper.com/rochester/AboutUs/Page" target="_self">
      
        Contact Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.rochestercitynewspaper.com/rochester/PrivacyPolicy/Page" target="_self">
      
        Privacy Policy
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://mailchi.mp/rochester-citynews.com/newsletters" target="_blank">
      
        Subscribe to our Email Newsletter
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.rochestercitynewspaper.com/rochester/work-with-us/Content?oid=10888717" target="_self">
      
        Work with Us
      
    </a>
    
    
  </li> 
  

      </ul>
    </div>
  





<div id="footerCopyright">
  <p>
   &copy; 2019
   City Newspaper.
   <br><br>
   Website powered by <a href="http://foundation.gyrobase.com/" target="_blank">Foundation</a>.
  </p>
</div><!-- GOOGLE ANALYTICS & QUANTCAST TAGS MOVED TO CODE FIELD OF SEARCH LOGIN COMPONENT -->

<!-- cXense script begin -->
<div id="cX-root" style="display:none"></div>
<script type="text/javascript">
var cX = cX || {}; cX.callQueue = cX.callQueue || [];
cX.callQueue.push(['setAccountId', '9222291968715708015']);
cX.callQueue.push(['setSiteId', '9222304501162646030']);
cX.callQueue.push(['sendPageViewEvent']);
</script>
<script type="text/javascript">
(function() { try { var scriptEl = document.createElement('script'); scriptEl.type = 'text/javascript'; scriptEl.async = 'async';
scriptEl.src = ('https:' == document.location.protocol) ? 'https://scdn.cxense.com/cx.js' : 'http://cdn.cxense.com/cx.js';
var targetEl = document.getElementsByTagName('script')[0]; targetEl.parentNode.insertBefore(scriptEl, targetEl); } catch (e) {};} ());
</script>
<!-- cXense script end -->
    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->

</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  
</div><!-- end gridCloser -->
    </body>
</html>
  


